Results 1 to 4 of 4
  1. #1

    Put in new battery...and NOTHING!

    I am a new ski owner with a 1995 SL650 and the previous owner said that the ski always starts right up and the only problem was that it would cut out every so often while they were riding..but never a problem with start up.

    I bought a new battery, charged it, and installed it properly and tried to crank it up and I got sound or anything. I know that I need a new electrical board and that is on the way but I wanted to see if the thing would crank anyway and it didn't.

    I have no idea what to check next...i filled the ski with gas and brand new oil and now I don't know what to do. I am at the point where I would pay for someone in the Cleveland area ot come and at least help me diagnose the problem. Any help would be appreciated. Thanks!


  2. #2
    absentx's Avatar
    Join Date
    Aug 2006
    Well, if you need a new electrical board, then that could be the problem, why dont you just wait till you get that in there?

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    Quick test in side the box.
    Find and see if you have power and ground to the solenoid, if not you need to see why you have no power or ground.
    If yuou have power and ground we'll tell you what to do next.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Call me. PM sent.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No Spark - Sea-Doo XP DI - New Battery and Plugs = No luck
    By cantera22 in forum 2-Stroke Performance
    Replies: 18
    Last Post: 01-11-2016, 04:22 PM
  2. Put key in and nothing
    By yol937 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-18-2013, 04:24 PM
  3. New Battery for the Pro and SLX!
    By bowsniper in forum Polaris Open Discussion
    Replies: 7
    Last Post: 08-10-2010, 10:12 PM
  4. I'm putting some new parts on my ski tomorrow
    By Green Hulk in forum 4-Tec Performance
    Replies: 16
    Last Post: 11-30-2008, 08:28 AM
  5. New Battery and I Get NOTHING!
    By kepneriphone in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-30-2007, 04:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts