Results 1 to 3 of 3
  1. #1
    bufaloz01's Avatar
    Join Date
    Jun 2007
    Location
    slc utah
    Posts
    47

    Pulling a motor on a 93 SL750

    Hey guys call me stupid but im having a problem pulling my motor. the only thing left in the hull is my crank case and in the manual it does not say anything about disconnecting the driveshaft from the motor it just says to loosen the hose clamps securing the coupler cover to the driveshaft coupler, and than remove the cover. than later on it says to slide the motor forward than lift out. My problem is its just not disconnecting from the driveshaft did I happen to miss something or should it just come out Thanks for the Help


  2. #2
    I've never tried leaving the pump and driveshaft in? It's possible on my Yami's but my 92 polaris won't let you move the motor forward enough due to the bulkhead! Z

  3. #3
    bufaloz01's Avatar
    Join Date
    Jun 2007
    Location
    slc utah
    Posts
    47
    Thanks for your fast reply ZMANN thats what i was thinking so ill just pull my pump no biggie appreciate the help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pulled the motor on my 99 xpl
    By pwc-loser in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-16-2011, 08:54 PM
  2. 95 carbs on 93 sl750
    By sl750-93 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-20-2009, 12:50 AM
  3. 93 SL750 back on the water
    By CynicCE in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-23-2008, 07:43 AM
  4. 93 sl750 seized motor
    By kabadou in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-07-2007, 10:19 AM
  5. I pulled the motor on my xp
    By ccassone in forum 2-Stroke Performance
    Replies: 1
    Last Post: 03-05-2006, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •