Results 1 to 4 of 4
  1. #1

    95 speedster noise

    I have a 95 speedster with a 650.The problem that i have is when I acelerat makes a grinding noise and dosent go Foward or revers.It sounds like the shaft came of the motor.I look and see that the shaft is still connected to the fly wheel could it be a bearing? Or is the shaft lose from the prop?

  2. #2
    Dr Len's Avatar
    Join Date
    Jan 2006
    New Jersey Attitude Capital of the World
    Sounds like your pump bearings. Pull the pump.When was the last time the pump oil was changed?

  3. #3
    sounds like stripped splines, remove the pump and check the splines on shaft and in prop, but more than likely be on the engine side pto or shaft

  4. #4
    Thank you its the pto.Do you know of anyone that has one .Its a 650 engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP noise @4750-4900 RPM's
    By RXPNJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2010, 12:54 AM
  2. no drive and bad grinding noise
    By timbo in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-27-2006, 10:40 PM
  3. Supercharger noises
    By vxrpete8 in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-28-2005, 07:03 AM
  4. Riva-Vortech SC Impeller---Noise
    By RXPDAVID in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-11-2005, 01:03 PM
  5. Break in period and Noise at 5000rpms on 05 GTX Limited
    By spc9669 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts