Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    battsy's Avatar
    Join Date
    Jun 2007
    Location
    Mn
    Posts
    51
    +1
    1

    7400 rpms normal with jerrys washers?

    Quick question for my first post. I recently bought jerrys washers and had the dealer in twin cities install them. Now I only see 7400-7450 rpms, 63mph. With my old ceramics I was easily 8000 and pulling much harder out of the hole. Are the washers slipping. Riding with my friends 2004 rxp with the old ceramics hes much faster, like I use to be.


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Welcome to the forum.

    first off, it sounds like the dealer did not install the washers correctly or set the torque properly...just my thoughts.....

    I would remove the SC, [easy to do] and send it to Jerry to check the assembly.

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Did your dealer install 04-05 washers into an 06 updated clutch?

    Here is how you tell the difference
    http://greenhulk.net/forums/showthread.php?t=30604

  4. #4
    battsy's Avatar
    Join Date
    Jun 2007
    Location
    Mn
    Posts
    51
    +1
    1

    battsy

    Jerry, the dealer installed the 04-05 washers in with the original clutch/supercharger that came with the machine when I first bought it in 2004

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    He may not have done something correct upon assembly. Possibly a spring washer flipped the wrong way..... or all of them

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    by the way, spring washers go like this: )()()
    If he did them like this: ))))) it would probably slip.

  7. #7
    battsy's Avatar
    Join Date
    Jun 2007
    Location
    Mn
    Posts
    51
    +1
    1

    Thanks alot jerry for your knowledge

    I dont know if i trust bringing my rxp back to the dealer to have them fix it again. I might try pulling it off myself and sending it down to you to make sure it is together right. What do you think?

  8. #8
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    it seems the service limit is easily reached on the spring washers in about 20 hours NEW being 10.5mm and the service limit being 9.70mm. my question is do they wear further than 9.70 or do you keep replacing them as well as shimming the washers to correct slipping problems????????? second do you they sell the shims in the online store???????

  9. #9

    Join Date
    May 2007
    Location
    Northern VA
    Posts
    85
    its possible youre dealer installed it wrong, however more than likely they have done hundreds of these.

    probably what happened is your spring washers didnt like being torqued down again and arent giving the right tension so your sc is slipping early. Im a big proponent of replaceing everything in the sc, not just the washers, because all the parts wear, including the shaft, gear, lock washer and spring washers. If anyone one of those parts has had excessive wear then it will always slip early.

  10. #10
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    might want to make sure the hose going between the SC'er and throttle body is tight and not leaking (boost leak) before you take it apart again. if not, send it to Jerry.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP 300 with 13 hours seeing only 7400 RPM
    By rx4pain in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-29-2016, 03:50 PM
  2. Does 2004 rxp with jerry washers need 06 clutch update
    By battsy in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-29-2007, 08:19 PM
  3. 7400 rpm's with new washers?
    By Dragdaddy71 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-09-2007, 11:24 AM
  4. RXT running 7400 rpm's
    By Chezzy in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-12-2006, 08:54 AM
  5. Interview with Jerry aka Greenhulk.
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-29-2006, 12:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •