Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3

    Look Ma! My SC Impeller is Chipped!

    i just finished installing something... which you will see a new thread on in a few more minutes.. and i stuck my arm and digi cam into the hull and snapped some pics to see what's goin on under the block, in the SC, and couple other places... Lookie what I found... SC has never been taken apart or touched ever.

    Where's the metal piece? I'd like to hope it was installed that way from the factory, but i'm being realistic. Anything you recommend investigating and checking for damage even tho it's kinda a small chip?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	chipped_sc_impeller_168.jpg 
Views:	110 
Size:	24.3 KB 
ID:	2419  


  2. #2

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Are you sure something didn't go in there?

  3. #3
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    steve this sux man, and ur right, where did that piece go? but now u can buy that new sc impeller to replace this one

  4. #4
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,360
    +1
    339
    Oh boy... that sucks Shib- now more decisions...

    Umm- pick up a Riva/Vortec real cheap?

  5. #5
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    Quote Originally Posted by jawz
    Are you sure something didn't go in there?
    no, i am NOT sure, .... what could have gone in there? The ski was completely stock for 95 hours of use the entire season.. it's been in my garage since beginning of december now and i've been slowly installing a few mods at a time

    give me the path that this metal bit can travel thru the engine and what damage COULD happen? please advise, i'm kinda not sure if i should care or not yet.. i guess because i don't have a clue about the severity of what you see in that picture.

    Vic... check your PM in 2 minutes.. typing something to you

  6. #6
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,812
    Steve,

    Don't you have the RR Intercooler? Maybe it could be laying in there hopefully?

  7. #7
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    nope, never had an external intercooler on it yet... just installed extended bars, grips, throttle, thru-hull exhaust, and air intake in the past month.... it has not been in the water since it's been modded.

  8. #8
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    9,367
    +1
    623
    Take her to your Brothers at your dealer ship and do a comp test. This will show you real quick. Steve there is a good chance it could of just passed stright through your engine with no damage.

    I hope you are OK.

  9. #9
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    yea i'm OK of course i'm not worried because if there's any issue i know i got a mechanic, well a friend before a mechanic, that will do whatever it takes for me and I can trust him with my ski and my life... but still sorta sucks i guess

    I'm gonna be down at the shop with it tomorrow and screw around with it and see what Rob thinks... WAS planning on riding tomorrow to do some testing

    question is what hit the impeller to make it chip and where are both of those items now... or maybe the material oc cast impeller was weak at that point and chipped off? i dunno...

    don't know if this has ANYTHING to do with it, but when i removed my stock exhaust for the thru-hull, i found a washer inside one of the stock exhaust tubes, hmmmm

  10. #10
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,360
    +1
    339
    Well, we know that the stock air intake has no filtration at all... not a big fan of that- anything loose and flopping around inside the hull has the potential to be sucked into the air intake (and I'm sure we have all found a thing or two straggling around).

    The good news is that if any damage was going to be caused by that chip-I believe it would have happened right away- I think it would be sucked into the intake immediately. The most likely suspect for damage would be valves. If that didn't happen yet- you might be very lucky...

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for a stock impeller for a 06 gp1300r
    By perchh in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-09-2010, 04:21 PM
  2. Looking for the right impeller
    By Sheepfu in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-10-2010, 11:07 AM
  3. Looking to but D-plate and chip
    By Metal4130 in forum Yamaha Classifieds
    Replies: 1
    Last Post: 08-15-2008, 12:49 AM
  4. looking for that perfect impeller for my 15f
    By wave15stx in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 01-08-2008, 09:03 AM
  5. Looking for help with impeller decision. 14/19 15/20 15/19
    By excess in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-16-2006, 07:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •