Results 1 to 2 of 2
  1. #1

    piston trouble on msx150

    the trouble is that I only get half rpm and the engine only starts on the initial start after that it will not start up till it cools down . I spoke to the dealer ad he tod me that the compression was good .I let a local mechanic listen to it while attempting to start it up and he told me that the piston was gone . Do I need to take the engine apart to confirm this . Alos there was a siver metallic liquid film on the plugs when I took them out . can someone help me here ..Got new battery and new plugs ..also replacing impeller as its all banged up .
    thanks


  2. #2

    Join Date
    Apr 2006
    Location
    panama city beach 'fl
    Posts
    1,846
    +1
    9

    Cool

    you need to have someone do a leak down test or find shop with bore scope

    later cd

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. piston trouble
    By motoxracing782 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-13-2008, 05:09 PM
  2. What is the piston clearance on a 785?
    By dirtracer4 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-31-2008, 02:02 PM
  3. piston rings on a sltx 1997 1050 motor
    By grifter in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 04-01-2008, 11:54 AM
  4. retorquing head on msx150
    By fast1983 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 06-18-2007, 04:47 PM
  5. Piston Wash on Tour to Orlando FL
    By mtrager in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 05-11-2006, 07:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •