Results 1 to 9 of 9
  1. #1
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852

    Green Wheel Results

    I kind of touched on it in my "I had a GEO weekend" thread. But here's the deal.

    Water Temp 89
    Air temp 89
    humidity 2000% (seriously though, I don't know, just really humid.)
    RPM's 8100
    Boost 8.7
    edit: fuel....completely full

    -Holeshot.....sucked cause my pump is leaking like a siv, but throttle response is great!
    -midrange....pulls like a freight train
    -top end....only 71.6 (it ran 71-72 earlier this summer pre-greenwheel) I assume my super leaking pump is to blame.

    I know it's not complete because of the water fountain I call a pump right now, but thats what happened.

    I also run the stock intercooler, so I don't know if the boost is right, or I might have a small leak. Though, I bet 8.7lbs is all I can expect with the stock IC


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    I think I know someone that should get an external ICCCCCCCCCCCCCCCCC......

  3. #3
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Quote Originally Posted by Danny View Post
    I think I know someone that should get an external ICCCCCCCCCCCCCCCCC......
    OH trust me...I was all about it until the rest of my weekend cost over 2g's

  4. #4
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    What do you mean by your pump leaking?

  5. #5
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Quote Originally Posted by GOLD06RXP View Post
    What do you mean by your pump leaking?
    the housing in the back, where the impeller is. It seals to the hull(well pump shoe actually, but you get the point.) and where they join, there is a rubber/neoprene seal. I'm pretty sure I probably pinched/damaged that seal when I flipped my wear ring a while ago.


    where it bolts up


    pump and steering nozzle/reverse bucket removed from ski
    Last edited by SeanCucf; 07-30-2007 at 12:08 PM.

  6. #6
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by SeanCucf View Post
    the housing in the back, where the impeller is. It seals to the hull(well pump shoe actually, but you get the point.) and where they join, there is a rubber/neoprene seal. I'm pretty sure I probably pinched/damaged that seal when I flipped my wear ring a while ago.


    where it bolts up


    pump and steering nozzle/reverse bucket removed from ski
    Those rxp rubber seals pinch easy. Use an older style 951 pump seal. It's a tighter fit, thicker, more seal surface & won't pinch. Just smear a thin layer of your favorite lube on the seal before installing. I've been using it for some time now without issues & I swap props all the time. You will need to torque the bolts evenly as you go because you will have a 1/4" gap to press in once the pump is pressed on by hand.

  7. #7
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    didn't know the 951 tip....thanks. You lube those? I just wipe them off with some windex.

  8. #8
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,210
    +1
    198
    Quote Originally Posted by SeanCucf View Post
    didn't know the 951 tip....thanks. You lube those? I just wipe them off with some windex.
    It's a tight fit so I spray some sd lube & wipe it down.

  9. #9
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852

    Angry

    beggining of day.......8000-8050 RPMs... boost 8.7lbs...... (no RPM gain after Greenwheel install)


    end of day......7900 RPM's.....boost 7.1lbs......speed: never over 71.... who cares, where's my boost!!!

    damn, I'm getting mad. Now I've gotta chase a boost leak

    Gotta pay to play

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. S3 Charger Or Green Wheel
    By FAST RXP in forum 4-Tec Performance
    Replies: 38
    Last Post: 12-05-2007, 09:31 PM
  2. My Green Wheel Results
    By Dark_viper42 in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-19-2007, 09:13 AM
  3. green wheel or riva vortech?????
    By scooter37x in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-10-2007, 01:05 AM
  4. Best supercharger wheel?? Green wheel??
    By codymouse54321 in forum 4-Tec Performance
    Replies: 18
    Last Post: 07-05-2007, 08:16 PM
  5. aNyone test the green wheel yet?
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-03-2007, 10:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •