Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    ultra 250 performance

    I'm disappointed with my machine, trying to figure out if anything is wrong with it.
    WOT 7300 rpm 10 pds boost, 59 mph GPS
    2200 FT above SL, 3/4 tank 230 pd rider.
    14 hrs
    Does this seem right for a stock machine ?


  2. #2
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    is that what your speedo is telling you?

  3. #3

    Join Date
    Apr 2007
    Location
    Melbourne, FL
    Posts
    183
    He said GPS so I assume the speed is accurate. Your RPM is low. Oil maybe high. Spend some time browsing through some of the posts here regarding RPM.

  4. #4
    SeaDoocer
    Guest
    Also,
    Check the threads on the dip stick problems which cause the oil to push down lower when replacing the dip stick..hence, give a false low reading.

  5. #5
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    check your plugs, i found the iridums rin alot better

  6. #6

    power/plugs

    I can check the oil dipstick etc, replaced all the plugs with factory originals, no difference, speedo reads low at 54 GPS was 59.4

    Have you got part number/serial no for iridium plugs?

    regards
    Rick

  7. #7
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    Quote Originally Posted by docricky View Post
    I can check the oil dipstick etc, replaced all the plugs with factory originals, no difference, speedo reads low at 54 GPS was 59.4

    Have you got part number/serial no for iridium plugs?

    regards
    Rick
    ngk cr9eix part # 3521

  8. #8
    SeaDoocer
    Guest
    [quote=docricky;360102]I can check the oil dipstick etc, replaced all the plugs with factory originals, no difference, speedo reads low at 54 GPS was 59.4


    Did you adjust your oil stick to read correctly?
    http://www.greenhulk.net/forums/showthread.php?t=33559

  9. #9
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Your also at 2000 ft above sea level, try riding a lil bit lower around you if possible see if the RPMs come up.

  10. #10

    oil change

    Thanks for the advise, I suspect the oil is the problem had 1 carboned plug, how do I drain the oil, check the air filter ?

    regards

    Rick

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki Ultra 250/260/300/310 Performance, Maintenance, and Information Database
    By smokeysevin in forum Kawasaki PWC Performance (4-stroke)
    Replies: 29
    Last Post: 11-27-2015, 12:23 PM
  2. FS ultra 250/260 performance parts
    By FAT BOY in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 02-13-2011, 09:31 PM
  3. Ultra 250/250 High Performance Adjustable CAM's.
    By Skips313 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 51
    Last Post: 10-18-2009, 02:35 PM
  4. ultra 250 performance module
    By rckid999 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 04-19-2007, 07:58 AM
  5. Ultra 250!
    By BRobertson in forum Kawasaki PWC Performance (4-stroke)
    Replies: 258
    Last Post: 11-12-2006, 09:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •