Results 1 to 7 of 7
  1. #1

    Question 1997 Polaris SLX 785 pro

    Can anyone lend some help: I was riding the other day and it seemed that the motor had seized, after getting it to shore it fired right up but now I have lost well over 1000 rpm, I pulled the rear cylinder off and appears to have a scratch in the wall on the exhaust side, could the piston have explanned when hot and caused the rings to stick the piston? The lower end seems fine, nothing appears to have gone through the motor, so do I get a new set of Pistons and put her back together? If so can you direct me on where and what is the best? Thanks for your time. Darren
    Last edited by heatherdarren; 07-30-2007 at 06:31 PM. Reason: spelling


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Darren,

    Welcome to the Green Hulk Forums!!

    Did you do a compression check before you pulled the domes off? If so, what were your numbers?

    Do you have any idea why it siezed? Any warnings on the MFD? Can you post pictures of the top of the pistons?

    Sounds like a top end rebuild is in order but it is very important to find the cause of the problem so your rebuild efforts are not in wasted?

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    can you take a pic of the piston even if its just the top if its a wiseco if may have expanded to much .

  4. #4
    Compression is 150psi in each of the three cylinders and no warnings where noted. I'll take some pictures tomorrow when I get home from work, thanks for the input. Darren

  5. #5
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    Have you checked the jet pump bearings?

  6. #6
    No, should I be concerned, when i pulled the pump off I didn't notice anything out of the ordinary

  7. #7
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    34
    Just a suggestion.If the bearings locked up,it would match your description of lacking RPM .Make sure impeller turns smooth and easy.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 Polaris slx 785 pro rebuild
    By Chuck785 in forum Polaris Projects
    Replies: 29
    Last Post: 07-05-2015, 12:15 PM
  2. Polaris SLX 785 Pro - Problems
    By koryk in forum Polaris Open Discussion
    Replies: 10
    Last Post: 03-08-2011, 01:09 PM
  3. WTB NEEDED - Drive shaft and coupler for Polaris SLX 785 PRO
    By koryk in forum Polaris Classifieds
    Replies: 2
    Last Post: 02-20-2011, 12:25 PM
  4. Polaris SLX 785 Pro - Pump/Drive line HELP!
    By koryk in forum Polaris Open Discussion
    Replies: 14
    Last Post: 02-20-2011, 04:06 AM
  5. FS 97 Polaris SLX 785 Pro $2500
    By yeehaa in forum Polaris Classifieds
    Replies: 8
    Last Post: 03-14-2010, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •