Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    1996 SLT780 Multi-Function Display Woes

    Just purchased two '96 SLT780's with both Mult-Function Display's not operating. Any suggestions on troubleshooting?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Check the fuse in the e-box.

  3. #3
    Quote Originally Posted by beerdart View Post
    Check the fuse in the e-box.
    Is this in the main electrical box where the primary reset is?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Yes and it is 1/4 amp.

  5. #5
    Great, I'll try that tonight.

  6. #6
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hi juiceman, WELCOME to the Green Hulk Forums!!!!
    Remember not to jump start your craft or crank using a low battery with the MFD plugged in as you may fry it or the fuse.

  7. #7

    Continuing MFD issues

    Good morning. Based on feedback received last week, I replaced the MFD fuses on both SLT780's (both were blown). One MFD came to life and works great. The second MFD has a "LOPR" reading on it. Based on the user manual this indicates a battery problem. Replaced the batter with a brand new one - still getting the LOPR reading on the MFD. Any thoughts?

  8. #8
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Try recalibrateing the MFD.

  9. #9
    Thanks Tony - any thoughts on how this function is performed?

  10. #10
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by Juiceman99350 View Post
    Thanks Tony - any thoughts on how this function is performed?
    Copied from the tech section : http://greenhulk.net/forums/showthre...highlight=LOPR

    To re-set the MFD
    Press and hold the MODE and SET keys until the CAL displays. The CAL display will usually show after 4 seconds
    Press and hold the SET key
    While continuing to hold the SET key ans within 2 seconds of pressing the SET key, press and hold the MODE key
    Don't release either key until the MFD shuts down
    After the MFD has shut itself down, press the mode key to turn the MFD on
    Depress the MODE key repeatedly until voltage is displayed and verify that the voltage reading has been restored.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 WaveRaider 1100 looking for multi function display
    By Wristpin in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 09-02-2010, 09:44 AM
  2. 95 Polaris SL 750, MULTI FUNCTION DISPLAY . please help
    By 750slt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-30-2009, 10:56 PM
  3. **Help Needed - Multi Function Display
    By bradcope in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 01-16-2009, 11:08 AM
  4. WTB mfd multi function display 8 pin for polaris sl 1050
    By boatinj in forum Polaris Classifieds
    Replies: 26
    Last Post: 01-01-2009, 07:43 PM
  5. 95 vs 96 multi function display
    By 95yami701 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-21-2008, 06:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •