Results 1 to 8 of 8
  1. #1

    Got my NEW genuine polaris tach off ebay, is it busted?

    Well just got in the Polaris tachometer that I got off ebay. Was in original package, but had been taped back up looking as if it was opened briefly. Everything appears to be there, however upon closer look I notice the tach is stuck around 2k rpm. What's the deal with that. Are these things serviceable and perhaps I can open it up and reset the needle? Ugh, this sucks. Here's some pics.

    Even my cat couldn't figure it out.


    Old digital camera takes horrible pics, but you get the idea.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Split the box, attach it and fire her up I'll bet the RPM's show correcty.

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I THINK on some of them at the rear was a rubber seal which could be removed and the needle adjusted.
    But hook it up and see if it seems correct.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Come to think of it, if you attach the power and ground it will probably drop to 0 RPM.

  5. #5
    Quote Originally Posted by ph2ocraft View Post
    Split the box, attach it and fire her up I'll bet the RPM's show correcty.
    woohoo that's what I was hoping for. CDI for my 750 is coming in tomorrow, we shall see in the next few days! Might take a little trial and error, there's two different hookups for the 650 and the 750 according to the tach instructions, and mine's gonna be a 750 motor, with a 750 CDI in a 650 e-box. Thanks Al.

  6. #6
    Touched power and ground, and tach smoothly went to zero just like ph2ocraft said. Disconnected it and the needle gently climbed again, which was interesting. Guess it's a wierd tach thing. But that's a relief, thanks again Al.

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    What are the differences?
    It seems it should be
    Yellow for tach signal
    Red for switched power
    Black for ground

  8. #8
    Bernie's Avatar
    Join Date
    Aug 2006
    Location
    Perth Australia
    Posts
    902
    +1
    1
    It was measuring your heart beat


    Cheers


    Bernie

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Got my new Ultra!
    By Pistonwash in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 04-02-2007, 07:16 PM
  2. Check out my new performance Polaris
    By Ilovepolaris in forum Polaris PWC Performance
    Replies: 2
    Last Post: 11-16-2006, 10:13 AM
  3. Got My New RXP!
    By Flynfox in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 10-02-2006, 12:12 PM
  4. got my new Rude Performance controler in!
    By beachboy66 in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-16-2006, 09:15 PM
  5. Got my new RXP hauler today.....
    By boataddict in forum Sea Doo Open Discussion
    Replies: 22
    Last Post: 12-09-2005, 01:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •