Results 1 to 2 of 2
  1. #1

    Join Date
    Aug 2007
    Melbourne AR.

    Poor throtle response

    On a Sportster LT with twin 720's, what would cause one engine to hesitate and rev slowly as if it was under a load while the other engine revs just fine? After 5 or 10 seconds and backing off the throttle a few times, it revs up with the other engine. just cant figure it out. Any comments would be great


  2. #2
    Dr Len's Avatar
    Join Date
    Jan 2006
    New Jersey Attitude Capital of the World
    Check you intake manifold for cracks. I had a hair line crack in mine. Make sure you look real good

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Genesis Ficht DI, had poor throttle response, now no start
    By jetski4ever in forum Polaris Projects
    Replies: 33
    Last Post: 05-12-2013, 04:49 PM
  2. Replies: 1
    Last Post: 06-19-2010, 04:36 PM
  3. RXP poor steering response??
    By mlidzct in forum 4-Tec Performance
    Replies: 10
    Last Post: 01-24-2010, 06:30 PM
  4. 95 SL750 Poor Throttle Response
    By christian79 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-14-2007, 11:52 PM
  5. Throtle Body issues
    By ActionR32 in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-01-2005, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts