Results 1 to 2 of 2
  1. #1
    Minx20's Avatar
    Join Date
    Nov 2006
    Location
    Ft. Lauderdale
    Posts
    177

    Arrow 1996 WaveBlaster II

    Need some help.

    My buddy has a WaveBlaster II and the gauge panel does not light up at all. Other than this the ski runs great. Is there a fuse to look for that might be keeping the panel from working. The gauge panel looks like a series of red leds that indicate fuel level etc.

    Thanks for the help.


  2. #2
    there is a fuse in the black box just in front of the battery have a look at that one
    if not i think there is one next to the steering pole i think dont hold me to it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Yamaha Waveblaster II part needed
    By jmrinlc in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-08-2011, 05:11 PM
  2. FS 1996 yamaha waveblaster ii 760
    By T-DUB in forum Yamaha 2 Stroke Skis
    Replies: 0
    Last Post: 05-20-2011, 11:45 PM
  3. FS 1996 yamaha waveblaster ii
    By T-DUB in forum Yamaha Classifieds
    Replies: 0
    Last Post: 09-11-2010, 10:45 PM
  4. 96 Waveblaster II ?'s
    By airbornexp in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-09-2008, 05:34 PM
  5. 96 yamaha waveblaster II surf?????
    By Rxp BLazin in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 05-01-2007, 11:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •