Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250

    How can tell when motor is gone??

    Any one can help to figure this out?

    I was cruising about 7000 rpms and then just stops,like when the battery is dead just clicks,any body? please,edwin


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    did you try a new battery?

    can you turn the motor over by hand?

  3. #3
    bttek1's Avatar
    Join Date
    Aug 2005
    Location
    South Florida
    Posts
    356
    Hopefully all that is wrong is your jet pump siezed up. This happened to a friend of mine a while back. Exibited the exact same symptoms as what you described.


    Hopefully this is all it is.. Other things that will cause this is a snapped rod, hydro-locked engine..etc..etc...




    Quote Originally Posted by edvazquez View Post
    Any one can help to figure this out?

    I was cruising about 7000 rpms and then just stops,like when the battery is dead just clicks,any body? please,edwin

  4. #4
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    yep, that sounds about right...

    i know how i can usually tell when my motor is about to break... when i get on it, i ride it, and say to myself, DAMN! this thing has never run so well... then i hear a few clicks and taps and clunks and get towed in... they always run their best before the blow up, LOL

    take the spark plugs out and see what they look like... take the jet pump off and see if it's locked up... then take the intake off the SC, and put a 17mm socket on the SC impeller nut and try to turn the SC clockwise while looking down the spark plug holes to see if the motor is turning or not... if not, then the motor is either locked up, or the SC is slipping really low, or a combination of the two

    you can also try taking a screw driver and jump the positive terminals on the starter relay and see if the motor trys to crank to eliminate any electrical problems

  5. #5
    mxl16's Avatar
    Join Date
    May 2005
    Location
    Central NJ
    Posts
    1,590
    edwin, id help u figure it out but u never come over!! i got a compression gauge. we're down in NC onvacation for the next 2 weeks. u can go to sears and get a nice craftsman for like $70.

  6. #6
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    I will try to check the spark plugs and the jet pump now, also i will post some pics.
    I know mike but you know to much damn work,i take off yesterday i see what happend

  7. #7
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    I think i found the problem. One of the s/c wheel blade is gone,now what i shuold do?

    Where the blade going? inside de motor?thannks

  8. #8
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    I shake the s/c on sounda like all those pieces are inside

  9. #9
    Im a Rude guy
    Join Date
    May 2005
    Location
    cape coral florida
    Posts
    250
    Open the s/c and wheel looks like crap also on the back of thes/c where the shaft meet the s/c housing you can see pieces of metal,this could be the bearings? plus the shaft is loose.

    Can i start the motor with out the s/c?
    Thanks

  10. #10
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    take the SC off the motor, and hold the throttle WOT and hit start for a second... see if motor is still llocked up or not

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how to tell what prop is installed without removing
    By owhat in forum 4-Tec Performance
    Replies: 19
    Last Post: 12-31-2011, 12:04 AM
  2. Start , when motor is hot
    By Philou548 in forum MSX/Matrix
    Replies: 6
    Last Post: 12-13-2011, 09:31 PM
  3. Purchasing 04' RXP how to tell if sc is bad?
    By rmk82nd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-01-2011, 09:51 AM
  4. how to tell when to rebuild carbs??
    By killcraft in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-03-2009, 12:09 AM
  5. how to tell if stater is bad
    By aaronpromotions in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-18-2008, 11:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •