Results 1 to 3 of 3
  1. #1
    xsantia's Avatar
    Join Date
    Nov 2006
    Location
    Israel
    Posts
    60

    Check engine MSX140!!!

    2 days ago i came home after the nice racing, after one weak went ones tot he race,but see that in the display red led and temperature worning, maximum engine RPM is 2500 only, i'm checked termostat, replaced him, take it out , the thome problem, when i'm open flash drain, after thome seconds, led is down and motor is work good, but with thome drops, after another thome minits,the same ,led, RPM, display hetter, and once more, intake are is cleaneng, all hoses is clean, what to check,what to do


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    I would go through all of the cooling hoses and the exhaust pipe.
    Remove each section of hose and blow some compressed through them.
    Pay particular attention to the nipple screwed into the top of the exhaust pipe, remove and clean it.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	order.jpg 
Views:	47 
Size:	300.1 KB 
ID:	33947  

  3. #3
    xsantia's Avatar
    Join Date
    Nov 2006
    Location
    Israel
    Posts
    60
    Nippel, i'm dusnot loock it ....mmm, need check,so in the servise manual, i did not see him.... and what about water temperture sensor? how to check him?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. mod ecu on o5 rxp- check engine, knock sensor
    By friebe1 in forum 4-Tec Performance
    Replies: 4
    Last Post: 12-27-2011, 02:25 AM
  2. why does check engine come on
    By macattack in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-01-2005, 10:16 PM
  3. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM
  4. Check Engine Light
    By meeper in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-27-2005, 04:24 PM
  5. Getting "Check Engine" message on 04 RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2005, 01:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •