Results 1 to 5 of 5
  1. #1

    Join Date
    Jul 2007
    Location
    Fort Mill, SC
    Posts
    3

    2002 Seadoo Sportster LE engine/impeller problem?

    Hey Guys,

    New Seadoo owner here. I've had my boat a few weeks now and I'm having trouble with it getting up out of the water. I'm not sure if its an engine problem( single engine 2 stroke) or a problem with the impeller/ wear ring.

    The boat will run fine at low rpms. But its not even getting out of the water if I push it up to around 7k rpms. It will get going ok if I'm the only person in the boat but if someone is with me it won't go at all.

    Any advice before I take it in to the dealership and bend over? Thanks.


  2. #2
    braveit1's Avatar
    Join Date
    May 2007
    Location
    Jacksonville, FL
    Posts
    44

    impeller problems

    The easiest thing you can do is use a flash light and look at the impeller. If there are marks where the impeller turns it could be the wear ring, especially if they feel deep. Changing the wear ring is very easy. Oder the part from here or your favorite provider, remove the four bolts from the reverse gate assemble and the four bolts from the pump nozzel. Pull out and place the new ring and the old assembly in the freezer. After 1/2 hour or so swap rings and reassemble. You can also get a good look at the impeller once you have gotten this far.
    Search the fourm for more details.

    My biggest problem when I did mine was that the manufacture/ deeler had crossed threaded the bolts and I had to extract them and replace them with new ones.

    I'm not a mechanic but I think that if you can pull 7K rpm on the engine then it's probally the wear ring or impeller.

  3. #3
    I had an 03 Sportster LE a couple years ago.....If the impeller & ring are good make sure your plugs are in good shape.

    I would go through 2-3 sets per summer as the 2 stroke really ran hot

  4. #4

    Join Date
    Jul 2007
    Location
    Fort Mill, SC
    Posts
    3
    Quote Originally Posted by mgurgone View Post
    I had an 03 Sportster LE a couple years ago.....If the impeller & ring are good make sure your plugs are in good shape.

    I would go through 2-3 sets per summer as the 2 stroke really ran hot

    Yea I already replaced the plugs and it still has the same problem. I'm gonna look into changing the wear ring and hopefully that will correct the problem. Any other problems you had with the 2 stroke I need to know about? Thanks for the help so far.

  5. #5
    RogerinSC----No....the only problems I ever had with the 2 stroke boat was keeping up with the spark plugs.

    FYI---I have changed the impeller & wear ring on my SCIC, make sure you have all the tools listed in the instructions...you'll need them.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 seadoo gtx 155 ecu/mpem problem?
    By hondarc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-27-2014, 11:51 AM
  2. 2002 Seadoo GTX DI 2 stroke problems with intermitant dieing
    By traviscl in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-25-2012, 11:07 AM
  3. Seadoo rxtx rebuilt engine rpm problem
    By Ali in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-16-2011, 02:34 PM
  4. info on a 2002 seadoo sportster
    By scubadad in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 01-09-2008, 01:37 PM
  5. 2002 Seadoo Sportster LE engine/impeller?
    By RogerinSC in forum 2-Stroke Performance
    Replies: 0
    Last Post: 08-04-2007, 02:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •