Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127

    07 rxp 20 hours cavatates but runs 70mph

    hey guys my rxp cavatates bad out of the whole like it's a clutch slipping on a car but it eventually hooks up and runs 70 mph on speedo at 8120 rpms. do u think my wera ring is shot ? also makes a rasttling sound from prop when idling on trailer also noticed after a ride that the ride plate is really hot to put ur hand on . any ideas thanks


  2. #2
    Quote Originally Posted by chokehold View Post
    hey guys my rxp cavatates bad out of the whole like it's a clutch slipping on a car but it eventually hooks up and runs 70 mph on speedo at 8120 rpms. do u think my wera ring is shot ? also makes a rasttling sound from prop when idling on trailer also noticed after a ride that the ride plate is really hot to put ur hand on . any ideas thanks
    Check the wear ring and nose cone of the prop!

  3. #3
    rior1's Avatar
    Join Date
    Feb 2007
    Location
    uk ESSEX
    Posts
    356
    sounds like a wear ring have u sucked up any stones?
    look up the intake grate or take your pump of and have a look ,check your impellar to
    mine was shot to hell but i still had good top end

  4. #4

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    i can see some knicks on the prop from underneath . how do i check nose cone?

  5. #5
    .... RXPwildchild's Avatar
    Join Date
    Jun 2007
    Location
    Wake Forest, NC
    Posts
    239
    +1
    1
    Definately sounds like the wear ring. I noticed some cavitation in mine earlie today. Late this afternoon, it took a turn for the worse. It is now somewhere in that river in the sky, playing with all the other long lost wear rings. May it rest in piece. *tears*

  6. #6

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    how much would it cost to change wear ring and is it warranty? do i need special tools ? thanks

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    $40-60 for a new plastic one. $180 for a stainless one. you can go through plastics every week depending on how you ride. stainless are a lot more durable as you can see by the price. simply take the pump off, take the two halves apart, put the 1 half in the freezer that has the wear ring, after 1 hour or less the plastic wear ring will slide out with ease.

  8. #8

    Join Date
    Jul 2007
    Location
    hawkesbury ontario
    Posts
    127
    ok put a new wear ring in the other had gouges in it . prop had a few knicks nothing major. when i gop to pull a skier out of the water sea -doo cuts out or is cavatating rpms go up to 8200 which i think is high .when not pulling it doesn't seem to do it. any ideas? thanks

  9. #9
    RNX's Avatar
    Join Date
    Jul 2007
    Location
    Lithuania
    Posts
    116
    i have the same problem, when i WOT from dead stop it cavitates and shows ~8200 rpm, but when i reach about 15-20mph it goes awesome and tops 70mph on dreamometer..the wear ring is new, no carbon seal leaking, the prop is in normal condition too..soon i'll try to install riva intake grate and solas 13/18 impeller, i think that will solve the problem. P.S. my RXP is totally stock now ( of course metal washers included )
    Last edited by RNX; 08-12-2007 at 02:55 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts I WILL BE IN FLORIDA 5-17.... 07 RXP 44 hours.. VIDEO 5-6-2014
    By ERICG1 in forum Sea Doo 4Tec Skis
    Replies: 13
    Last Post: 05-14-2014, 09:58 PM
  2. Replies: 4
    Last Post: 03-06-2013, 02:45 PM
  3. FS: 2008 RXP-X 20 Hours, Basic Mods $9700
    By Pilot_85 in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 04-01-2009, 09:18 AM
  4. 6 Hours On 07 Rxp Rpms
    By codymouse54321 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-15-2007, 03:55 PM
  5. 07 RXP very catastrophic ceramic failure at 5 hours
    By Green Hulk in forum 4-Tec Performance
    Replies: 92
    Last Post: 04-06-2007, 01:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •