Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: 7020 RPM's

  1. #1
    K-MAN_RXP#07
    Guest

    Exclamation 7020 RPM's

    Was riding a friend of mines RXP the other day and its only hitting 7020 rpm's and saying 64 on the gauge. What could be the problem as to why it is not running its full rpm's?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Stock ceramic washers?

  3. #3
    Quote Originally Posted by K-MAN_RXP#07 View Post
    Was riding a friend of mines RXP the other day and its only hitting 7020 rpm's and saying 64 on the gauge. What could be the problem as to why it is not running its full rpm's?
    high oil
    something caught in pump
    torn wear ring
    bent prop
    sc clutch slipping
    elevation
    weather conditions
    carbon seal
    pump shoe
    bad gas

    The list goes on and on...pick your poison. Start somewhere and start eliminating problems. You need to post more info to help narrow things down also. Do a search on low RPM and causes and such. Good luck and welcome to the forum.

  4. #4
    Quote Originally Posted by Ultra250 Tn View Post
    Stock ceramic washers?
    Are you ever going to buy an RXP? You spend a lot of time over here...go out, buy one, be happy.

  5. #5
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    No probably not, Im happy with the Kawi , thanks though, lol

  6. #6
    K-MAN_RXP#07
    Guest
    Thanks for the options 2 eliminate from.

  7. #7
    K-MAN_RXP#07
    Guest
    The props fine, the weather conditions here dont change. Its always HOT! and there were alot of other RXP's out there that were running normally. It got serviced saturday. My brother was suggesting that it could be the clutch slipping.

  8. #8
    How many RPM were you turning before? That's a good start. It's much easier to narrow down a list after knowing how many RPM you lost.

  9. #9
    K-MAN_RXP#07
    Guest
    Well he got it like that. (running the 7020) so we thought the service would have helped it. according to Riva there suppose 2 be running 8100 rpms. If thats correct he's far off. But on a average it should run somewhere between 7900 to 8100 which shows its running good. Also it doesnt have that pull that rxp's have which I know comes from the sudden response from the supercharger. And by the pull I mean when u sqweeze the throttle it feels like your being sucked back.

  10. #10
    K-MAN_RXP#07
    Guest
    Its has few performance parts as well. The air filter from Riva , exhaust I think its the power pipe ( Cant remember then exact name) and a blow off valve. another thing is, it reads 137.8 hrs. So theres more options 2 eliminate there.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP noise @4750-4900 RPM's
    By RXPNJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2010, 12:54 AM
  2. RXP RPM Limiting Question
    By Jarrett in forum 4-Tec Performance
    Replies: 40
    Last Post: 07-20-2007, 06:58 PM
  3. Can high heat and humidity take away 200 rpms?
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-08-2005, 12:46 PM
  4. What should stock RPM be running?
    By Compwhiz82 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-27-2005, 04:25 PM
  5. Replies: 1
    Last Post: 05-18-2005, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •