Results 1 to 9 of 9
  1. #1

    Another D plate Question re: CatSensor

    Just need to reclarify this issue....I had my d plate and new RIVA filter installed and I was told that I do not have to modify the chip...

    Took it out for 10 minutes and the heat light started to beep..... Took it back to the shop and was told that it was a faulty sensor which is very costly...

    Have been reading all the forums the chip is a must ..please advise..


  2. #2
    Caution raider fan in the area !!
    Join Date
    Jul 2006
    Location
    Sacramento, California, United States
    Posts
    1,834
    +1
    2

    Talking

    Sounds, Like You Kneed The Riva Cat Sensor Chip / Plug In .

  3. #3
    Hydrotherapy's Avatar
    Join Date
    Sep 2006
    Location
    The Rock
    Posts
    3,347
    +1
    17
    Quote Originally Posted by jetboy View Post
    Just need to reclarify this issue....I had my d plate and new RIVA filter installed and I was told that I do not have to modify the chip...

    Took it out for 10 minutes and the heat light started to beep..... Took it back to the shop and was told that it was a faulty sensor which is very costly...

    Have been reading all the forums the chip is a must ..please advise..
    what year gpr it makes a difference

  4. #4
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by jetboy View Post
    Just need to reclarify this issue....I had my d plate and new RIVA filter installed and I was told that I do not have to modify the chip...

    Took it out for 10 minutes and the heat light started to beep..... Took it back to the shop and was told that it was a faulty sensor which is very costly...

    Have been reading all the forums the chip is a must ..please advise..
    If you did need a sensor. You will find it here - since most of us have removed it. No way I would buy a new one.

  5. #5
    Gp1300r 2006

  6. #6
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30
    Did they install a cat sensor chip? I know someone with an 07 and when he installed the D-plate and sensor chip it would alarm, when he removed the chip and plugged the sensor back in it worked.

  7. #7
    Rookie
    Join Date
    Aug 2007
    Location
    houston
    Posts
    41
    thats wierd.. i have an 05 and the only mod i have done is the d plate. I put the chip in and it made my warning light turn on. removed the chip and pluged the sensor back in and have had no problems at all.

  8. #8
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,875
    +1
    30

  9. #9
    Rookie
    Join Date
    Aug 2007
    Location
    houston
    Posts
    41
    i am take back my statement about not having a problem at all. My buzzer goes on after about 30 min of nonstop cruizing but I was told to use a 10k resistor. Havent tried it yet though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pump transom re enforcement plates question?
    By 2fast4u in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 06-20-2015, 09:59 PM
  2. Another D plate question!
    By malibudave in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 12-12-2014, 08:18 PM
  3. Another D-Plate question!
    By Chrisrokc in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-20-2006, 03:06 PM
  4. Another Nils product question?
    By 01xdime in forum 4-Tec Performance
    Replies: 7
    Last Post: 11-14-2005, 04:30 PM
  5. Another water ingestion question
    By Denali44 in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-08-2005, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •