Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741

    interesting **PICS*

    oh how wonderful it is to be a PWC owner





    was doing some runs when that happend...

    and my XP800 has a blown motor, so im stuck on land for a while

    i've only owned the damned things for 2 months and everytime i take them out i have problems....

    Shoulda went with my gut instincts and bought an RXP... but i felt the need to have two boats so my g/f could ride, and turns out she's scared of riding them
    Last edited by mongorunner; 08-11-2007 at 11:58 AM.


  2. #2
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741
    anyone want two dead ski's? first 100 bucks takes them....

  3. #3
    WOW! , holy crapplastic batman!...
    Hope your up and running soon!...PR...

  4. #4
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    had that happen during practice in a race......... up over the bars and rode the hood past turn 3 onto the beach.... never doing that again

  5. #5
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    OUCH! I just had to replace prop,shaft & bearing $500 on my rxp so they all break but ya just pick out the bad pieces and roll with it!!!

  6. #6
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741
    did my pictures die for anyone else?

  7. #7
    mr. knowitall
    Join Date
    Jul 2007
    Location
    jacksonville fl.
    Posts
    156
    what do u think caused it ?

  8. #8
    Faster Than a Snail on a Log mongorunner's Avatar
    Join Date
    Jun 2007
    Location
    North of Amarillo TX
    Posts
    741
    Quote Originally Posted by southboundchicken View Post
    what do u think caused it ?

    no clue whatsoever...


    i had been running in the middle of a large cove for a while, not near the shoreline where a rock or anything could be picked up...

    came out of the cove into the main body WOT, then i heard a clank and a pop


    think im going to need a new wear ring??

  9. #9
    Quote Originally Posted by mongorunner View Post
    no clue whatsoever...


    i had been running in the middle of a large cove for a while, not near the shoreline where a rock or anything could be picked up...

    came out of the cove into the main body WOT, then i heard a clank and a pop


    think im going to need a new wear ring??
    looks like the blade just cracked. There are a few pics of this same thing floating around here...PR...

  10. #10
    Closed mouth no get fed,...... travelboysteve's Avatar
    Join Date
    Jun 2007
    Location
    Orange County
    Posts
    199
    Damn, Torquemaster-G is in the house!!!!!!!!!!!!!!!! Dude, That sucks,.......

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ROGUE RACING 2003 Pics of interest from back in the day.
    By MrRogue in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 01-25-2010, 11:28 PM
  2. Funny pic thread
    By Green Hulk in forum Open Discussion
    Replies: 43
    Last Post: 01-16-2008, 12:38 AM
  3. Interesting pic *Turbo 15F*
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 58
    Last Post: 11-18-2005, 05:11 PM
  4. A few pics of my almost finished 03 GTX sc
    By two2curupt in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2005, 09:54 AM
  5. Some pic
    By Jrsrxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-30-2005, 10:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •