Results 1 to 5 of 5
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    3

    My Clutch Failed the test bad, but never slipped

    Took my SC out of the ski today. Well I shouldn't say I did solely, i removed the bolts and Rob @ Formula One Marina did the rest. i dunno what I would do without him. and Jay was there dressed all pretty for moral support.

    anyways, 2005 RXT with stock original clutch and 93 hours. Both clutch washers were burnt to a crisp just at a first glance when he pulled the SC. and my oil looks pretty pitiful juding by what was dripping of the gears it was changed not long ago too

    Put it on the bench and did a slip test on it, and she failed it pretty badly... Kinda weird considering my ski never has slipped at WOT, never dropped less than 8100, and jsut the other day I ran 71+ mph with a 14/18.5 spinning 8100 rpms..

    today I installed the Les B kit with a new RR ECU, so i'm glad we caught the clutch before i went crazy with mods because I doubt it would have lasted much longer.

    After i find my abnormally high rpm idle problem tomorrow, she goes in the water for some testing


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316

    Re: My Clutch Failed the test bad, but never slipped

    Quote Originally Posted by Shibby1485
    Took my SC out of the ski today. Well I shouldn't say I did solely, i removed the bolts and Rob @ Formula One Marina did the rest. i dunno what I would do without him. and Jay was there dressed all pretty for moral support.

    anyways, 2005 RXT with stock original clutch and 93 hours. Both clutch washers were burnt to a crisp just at a first glance when he pulled the SC. and my oil looks pretty pitiful juding by what was dripping of the gears it was changed not long ago too

    Put it on the bench and did a slip test on it, and she failed it pretty badly... Kinda weird considering my ski never has slipped at WOT, never dropped less than 8100, and jsut the other day I ran 71+ mph with a 14/18.5 spinning 8100 rpms..

    today I installed the Les B kit with a new RR ECU, so i'm glad we caught the clutch before i went crazy with mods because I doubt it would have lasted much longer.

    After i find my abnormally high rpm idle problem tomorrow, she goes in the water for some testing
    she failed pretty badly.......what does that mean? what was the slip moment?

    when did you get the B kit? Can't wait to see the results of that

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    3
    forget the exact number... but slip test was in the low 50's inch pounds... the lowest parameter Seadoo has i believe is 66 in lbs or something? i dunno

    received the B kit yesterday, but it's not mine, she's a loaner for some testing... but i'm sure once i'm done playing with it i'll have to buy one for myself

  4. #4

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    I've said this before but here goes again.... Bearings and clutches every twenty hours.... It,s just not worth the pain in the ass. Maybe Les's clutch will be better...we'll see.

  5. #5
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    how easy r they to change?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The good and the bad of my weekend on the lake....
    By Dockside in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-06-2009, 07:34 PM
  2. Motor failed! (the one inside my head)
    By stuby in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-17-2009, 02:14 PM
  3. spinning my DF 14/24.5 out the hole bad!
    By flyboy in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 10-31-2008, 06:46 PM
  4. Finally got to test out my mods with the new prop.
    By Pinoy in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-07-2008, 11:40 AM
  5. lost my clutch today
    By Green Hulk in forum 4-Tec Performance
    Replies: 30
    Last Post: 06-14-2005, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •