Results 1 to 5 of 5
  1. #1
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3

    My Clutch Failed the test bad, but never slipped

    Took my SC out of the ski today. Well I shouldn't say I did solely, i removed the bolts and Rob @ Formula One Marina did the rest. i dunno what I would do without him. and Jay was there dressed all pretty for moral support.

    anyways, 2005 RXT with stock original clutch and 93 hours. Both clutch washers were burnt to a crisp just at a first glance when he pulled the SC. and my oil looks pretty pitiful juding by what was dripping of the gears it was changed not long ago too

    Put it on the bench and did a slip test on it, and she failed it pretty badly... Kinda weird considering my ski never has slipped at WOT, never dropped less than 8100, and jsut the other day I ran 71+ mph with a 14/18.5 spinning 8100 rpms..

    today I installed the Les B kit with a new RR ECU, so i'm glad we caught the clutch before i went crazy with mods because I doubt it would have lasted much longer.

    After i find my abnormally high rpm idle problem tomorrow, she goes in the water for some testing


  2. #2
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316

    Re: My Clutch Failed the test bad, but never slipped

    Quote Originally Posted by Shibby1485
    Took my SC out of the ski today. Well I shouldn't say I did solely, i removed the bolts and Rob @ Formula One Marina did the rest. i dunno what I would do without him. and Jay was there dressed all pretty for moral support.

    anyways, 2005 RXT with stock original clutch and 93 hours. Both clutch washers were burnt to a crisp just at a first glance when he pulled the SC. and my oil looks pretty pitiful juding by what was dripping of the gears it was changed not long ago too

    Put it on the bench and did a slip test on it, and she failed it pretty badly... Kinda weird considering my ski never has slipped at WOT, never dropped less than 8100, and jsut the other day I ran 71+ mph with a 14/18.5 spinning 8100 rpms..

    today I installed the Les B kit with a new RR ECU, so i'm glad we caught the clutch before i went crazy with mods because I doubt it would have lasted much longer.

    After i find my abnormally high rpm idle problem tomorrow, she goes in the water for some testing
    she failed pretty badly.......what does that mean? what was the slip moment?

    when did you get the B kit? Can't wait to see the results of that

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    forget the exact number... but slip test was in the low 50's inch pounds... the lowest parameter Seadoo has i believe is 66 in lbs or something? i dunno

    received the B kit yesterday, but it's not mine, she's a loaner for some testing... but i'm sure once i'm done playing with it i'll have to buy one for myself

  4. #4

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    I've said this before but here goes again.... Bearings and clutches every twenty hours.... It,s just not worth the pain in the ass. Maybe Les's clutch will be better...we'll see.

  5. #5
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    how easy r they to change?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I was ready for the MUD BUG but......
    By NCHeel in forum Mudbug Nationals PWC.Life Rally
    Replies: 11
    Last Post: 06-06-2007, 04:39 PM
  2. The Good, Bad, and The UGLY Stage 1 and 2 Mods
    By sr71bb in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-11-2006, 09:18 AM
  3. Are these clutch wahsers the the coated......
    By Jrsrxp in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-17-2006, 04:04 PM
  4. Liking the new gp1300r but...
    By FireFox in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-07-2005, 02:50 PM
  5. RR clutch fails at 1.5 hrs
    By CRS in forum 4-Tec Performance
    Replies: 47
    Last Post: 08-08-2005, 06:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •