Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455

    Massive Cavation on Take off (Ultra 250x)

    On take off I experience ALOT of cavation. After a few seconds it'll hook up. Current mod is R&D intake grate amd R&D pump shoe kit. Any ideas on what it could be? Thanks


  2. #2
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    check the rubber seal might be excess grease letting water slip through the pump seal n the hull

  3. #3
    Silence! I Keel You! earthshaker's Avatar
    Join Date
    May 2007
    Location
    Northern CA Coast
    Posts
    1,616
    +1
    2
    Did you have it before the mods?

    If not maybe check your sealing...

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by BERMY_BOY View Post
    check the rubber seal might be excess grease letting water slip through the pump seal n the hull
    Where exactly is that?

  5. #5
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by earthshaker View Post
    Did you have it before the mods?

    If not maybe check your sealing...
    It was there before the mods

  6. #6
    BERMY_BOY's Avatar
    Join Date
    Jan 2007
    Location
    bermuda
    Posts
    120
    Quote Originally Posted by BluUltra250x View Post
    Where exactly is that?
    you need to take the pump off u'll find it on the end of the pump

  7. #7
    Someone should post a step by step with pictures on how to fix the cavation problems

  8. #8
    TEEBEE's Avatar
    Join Date
    Mar 2007
    Location
    Southern Connecticut
    Posts
    146

    Wear Ring

    Quote Originally Posted by BluUltra250x View Post
    On take off I experience ALOT of cavation. After a few seconds it'll hook up. Current mod is R&D intake grate amd R&D pump shoe kit. Any ideas on what it could be? Thanks
    Take a good look at the inside of your pump. If there is some scoreing on the walls of the pump it will cavitate on takeoff and will only get worse.

  9. #9
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,563
    +1
    169
    mine was doing the same thing before all the bearings in it went bye bye.....

  10. #10
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by Region8Ultra250X View Post
    mine was doing the same thing before all the bearings in it went bye bye.....
    .

    So you replaced the pump?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 VXR cavatation on take off
    By Oldman on VXR in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 06-21-2014, 11:31 PM
  2. Timing mods on the 07 ultra 250X
    By PLYMO in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-29-2009, 02:34 AM
  3. Will the Ultra LX seat fit on my 2007 Ultra 250x ???
    By Kawi-Guy in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 12-11-2008, 04:43 PM
  4. SLT 780 hesitates on take off
    By paramuir in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-08-2008, 08:57 AM
  5. 14 hours, lost 200 rpms, hesitates on take off and bad vibration
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-13-2007, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •