Results 1 to 8 of 8
  1. #1
    Dragdaddy71 Dragdaddy71's Avatar
    Join Date
    May 2007
    Location
    Moline , IL
    Posts
    126
    +1
    1

    Where's my power and rpm???

    Ok, I know there is a million threads about boost leaks and all that but mine has not been apart. Just bolt on's. I have a 04 RXP stage 1 Riva kit with rear exhaust and b/o valve. I just had Jerry put new washers and bearings in my SC and put it back togather and what do you know it runs about 7300 RPM and about 62 on the speedo. So I order a new wear ring SS and install it, it changes nothing. WHERE IS MY POWER, I don't get it. I pulls flawlessly up to the 7400 but then nothing. Any help please??


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Perhaps the BOV is leaking. Do you still have your stock SC to TB hose you could reinstall just to verify?

  3. #3
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    If the tube ain't leaking, also check to see if the BOV was installed correctly...I know a few people that didn't drill the hole on the vacuum fitting...

  4. #4
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    Take the bov and throw it in the garbage where it belongs, and you should be fine.

  5. #5
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Quote Originally Posted by RXP Steve View Post
    Take the bov and throw it in the garbage where it belongs, and you should be fine.
    Well said.

  6. #6
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,677
    +1
    4
    Quote Originally Posted by RXP Steve View Post
    Take the bov and throw it in the garbage where it belongs, and you should be fine.
    I never ordered a BOV... probably because my trash can is already full of useless parts...

  7. #7
    Quote Originally Posted by RXP Steve View Post
    Take the bov and throw it in the garbage where it belongs, and you should be fine.
    Steve: This statement is so you!!!

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Where is my intercooler and where do i put antifreeze in it? (GTR215)
    By 3PedalMINI in forum Sea Doo How To & FAQs
    Replies: 6
    Last Post: 11-16-2013, 10:10 PM
  2. Loss of power and RPM after engine is warmed up ...
    By OBrienCJ in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-26-2011, 09:55 PM
  3. put on air intake, but lose power and rpms?
    By dreww in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 06-18-2010, 12:08 PM
  4. Polaris 750 SL - Where did my power go?
    By skidiva in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-13-2009, 10:22 AM
  5. Loss of power and rpm
    By 04DarkShadowGT in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-27-2009, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •