Results 1 to 10 of 10
  1. #1

    Battery Cables Reversed

    2002 Polaris "Freedom" (700cc).

    For the first time EVER, I hooked up a battery backwards. (yes, black ground to + terminal, and red cable to - terminal)

    Which was OK, until I hit "start". Fuel gauge went backwards, below "E", and the starter/engine did not crank... silence.

    When I tore back into it and discovered the error, I opened the electrical box (checking fuses). When I opened the box, a light puff of smoke escaped and it smelt like burnt electrical. No fuses are blown, but I'm sure I fried something(s).

    Which "things" do I need to buy ???? How expensive is this going to be ???


  2. #2
    Don't you love being watched?? milesengineer's Avatar
    Join Date
    Jan 2007
    Posts
    164
    Have you put the cables back on the right way and tried it yet? Also on most of the polaris' I have seen there is a circuit breaker on it that hopefully will pop when you do something like this. Check it out and get back to us on what it does.

  3. #3
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Welcome to the Green Hulk Forums Wood1067!!!

    Will it start now?

    If not, you should test the stator, the test procedure is in the "Tech Section" under "Domestic Electrical".

    Does the Freedom have a bildge pump? If so, is it running all of the time (when the engine is off). If yes, you probably fried the voltage regulator which is located in the electrical box and could explain the puff of smoke.

    Let us know what you find.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Welcome 1067!! ^^^^^^

  5. #5
    Cables were put back properly, engine cranks, but will NOT start. No spark.

    I have pressed the "reset" button numerous times, no change.

    It does have a bilge pump, activiated manually by thumb switch. It functions normally, NOT running all the time.

  6. #6
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Test the stator and let us know the results. Can you see what the source of smoke was in the electrical box?

  7. #7
    Multi-Meter is on it's way (loaner this weekend). I assume the "stator" is electrical, inside the electrical box since whatever is fried smoked inside there. Could not determine source of smoke. Electrical box is/was sealed enough that no smoke escaped, until I opened it - about 10 minutes after my f'up.

    I have found this link to be helpful...
    http://216.37.204.206/wps/Polaris_OE...e=13&A=99&B=10

    (2002, Freedom 3-pass, Electrical)

    I'm looking at #34, 8-wire stator ?

  8. #8
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Wood,

    There is a manual in pdf form in the tech section for your ski. It would be worth while to check it out. Here is the link.

    http://greenhulk.net/forums/showthread.php?t=35358

    The stator is located under the flywheel in the front of the motor. If we can determine if the stator is good then we can focus on other components.

    I am thinking that the cdi might have been the source of the smoke but there is no way to test it. The voltage regulator is the other "black box" inside the electrical box. Normally when they go bad the bildge pump will run all of the time.

    Look over the manual, the is a lot of good trouble shooting stuff in there.

    Let us know what you find.

  9. #9
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    here
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	jgnition.JPG 
Views:	66 
Size:	40.4 KB 
ID:	35272  

  10. #10
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    1067, any luck with this??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hot Battery Cables?????????
    By 00rx in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-05-2010, 10:56 AM
  2. FS Extended Battery cables
    By mrbtd in forum Conversion Skis Classifieds
    Replies: 3
    Last Post: 10-23-2009, 05:18 PM
  3. battery cable & plug wires $20.00
    By SLOANMAN in forum Polaris Classifieds
    Replies: 2
    Last Post: 08-04-2008, 12:24 PM
  4. Bad battery cable
    By smackwave in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-24-2007, 07:59 AM
  5. Quick question- Battery cables
    By seadoo951 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-15-2007, 05:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •