Results 1 to 10 of 10
  1. #1

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99

    Help with new pistons on SL 750

    I have a dilemma, is their a trick to get the cylinders down on the pistons. I am rebuilding my motor and Iam having a hard time getting the cylinders on the pistons. They have been bored and new pistons (.5) Also anybody have any reeds for a 93 SL 750. One more thing, is their suppost to be a gasket between the oil pump and the case?
    Thanks
    Joe
    Last edited by jmule98; 08-14-2007 at 09:35 PM.


  2. #2
    use your fingers to compress the rings while you drop the cylinders on and make sure the locating pins are in the gap of the ring!

  3. #3
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Read my post on installing pistons in my 780.

    http://greenhulk.net/forums/showthread.php?t=31248

  4. #4

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99
    Quote Originally Posted by ZMANN View Post
    use your fingers to compress the rings while you drop the cylinders on and make sure the locating pins are in the gap of the ring!
    What do you mean by in the locating pins are in the gap of the rings

  5. #5
    look into the ring grooves and there will be tiny pins that the eng gap on the rings centers on!

  6. #6

  7. #7

    Join Date
    Jun 2007
    Location
    Clay NY
    Posts
    99
    Quote Originally Posted by ZMANN View Post
    look into the ring grooves and there will be tiny pins that the eng gap on the rings centers on!
    ZMANN THANK YOU THAT DID IT

    Joe

  8. #8
    Cool! it's a common issue Keep us posted OK? Z

  9. #9
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    Make sure you use lots of premix on those rings, before install. As you do not want a dry start.

  10. #10
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by jmule98 View Post
    One more thing, is their suppost to be a gasket between the oil pump and the case?
    Thanks
    Joe
    It's an o-ring.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help with new engine install.... 1st start on xlt 1200
    By DieselNaz in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-17-2015, 01:17 AM
  2. In need of help on SL 750
    By Bigdog1597 in forum Polaris PWC Performance
    Replies: 38
    Last Post: 05-06-2015, 10:21 PM
  3. Help with new 750 SLTs
    By skigo in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-06-2012, 08:18 AM
  4. HELP with spark problem on 94 SL 650
    By gbripp in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 08-21-2008, 06:25 PM
  5. 1st ride with new piston
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-11-2006, 01:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •