Results 1 to 5 of 5
  1. #1
    Hypertoys's Avatar
    Join Date
    Jun 2006
    Location
    Riegelwood,N.C.
    Posts
    283

    OUCH!!! Crank Pictures

    Just wondering if anyone else has had this problem.This is the crank out of my friends 05 GPR with only 60 hrs.,and #1 & #3 were perfect.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0999.JPG 
Views:	67 
Size:	305.0 KB 
ID:	35130   Click image for larger version. 

Name:	IMG_0995.JPG 
Views:	61 
Size:	481.8 KB 
ID:	35131  


  2. #2
    BTWard454's Avatar
    Join Date
    Feb 2006
    Location
    Seymour, TN
    Posts
    56
    My 03 did the same thing at about 50 hours. It wasn't as bad as that, but destroyed none the less.

  3. #3
    Brian Thomas's Avatar
    Join Date
    Apr 2007
    Location
    East TN
    Posts
    246
    +1
    10
    lack of oil on #2??..........Oil line come off?.........boy, that rod got HOT!

  4. #4
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    Looks like water (hydrolock)

  5. #5
    Hypertoys's Avatar
    Join Date
    Jun 2006
    Location
    Riegelwood,N.C.
    Posts
    283
    We were racing and he said it just slowed down and cut off . He cranked it up and it started knocking and locked up. The oil line was on and there was no sign of hydrolock.The piston looked good ,just a little lean and I had to melt the piston to get it off .I am going to test the oil pump before I put back on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new RXP pictures.
    By dgmoore in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 04-28-2013, 10:51 AM
  2. piston or crank failure in the picture?
    By izik in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-28-2008, 07:09 AM
  3. Crank Carnage *Picture*
    By MPower in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-21-2007, 11:11 AM
  4. Pictures of my head being ported
    By Green Hulk in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-13-2005, 08:00 AM
  5. Pictures of Rotax Racing's new 300 HP system
    By Green Hulk in forum 4-Tec Performance
    Replies: 32
    Last Post: 05-12-2005, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •