Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2

    Almost sank it..........

    Went riding today. Engine only turned 7150 and actually bumped 7250 for a short time.(Any suggestions on this) After riding to see if it would get the rpms up I noticed the ski wasnt riding right. Well I popped the seat and behold, half a hull filled with water and youll never guess what caused it!

    A STINKEN SNAP TIE lodged itself between the carbon ring! Yeah, I couldnt believe it either.How the heck could that be?


  2. #2
    How did you find That? Glad you came out of that OK...PR...

  3. #3

  4. #4
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2
    Pulled it all apart after I got it home! Water was sucked into the intake and filled the supercharger also. Changed the oil twice so far, and sprayed wd-40 into the cylinders . Turned it over until all the water was pumped out! Once all that was done , I ran it for a minute and it seems fine! But I think im gonna try and get it out and ride it today to make sure the water hasnt set in. Good thing was , I was in fresh water for the most part!

  5. #5
    J3ff
    Guest
    How did that happen? Should i be worried about it happening on the honda?

  6. #6
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    glad to see ur ok and lets hope ur ski is also. before i go ride im checking everywhere on my ski for problems and running the ski on the trailer before running it on the lake.

  7. #7
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2
    Thanks man! Its still freaking me out! Im starting to think that calling in to work on friday is catching up with me!

  8. #8
    do you know how the tie got into the carbon seal?...PR...

    from the inside? outside?

  9. #9
    Rendog's Avatar
    Join Date
    May 2005
    Location
    jacksonville fl.
    Posts
    1,278
    +1
    2
    It was an old tie that was lying around in the hull! No idea whatsoever how it got lodged in there. I have a spritzing leak that still comes and goes, im thinking it has something to do with the bumper the rides in the front of the shaft, allowing the shaft to move fowards. I read this happened to VFX Im willing to pull the shaft, but dont you have to have a special tool?

  10. #10
    Quote Originally Posted by Rendog
    It was an old tie that was lying around in the hull! No idea whatsoever how it got lodged in there. I have a spritzing leak that still comes and goes, im thinking it has something to do with the bumper the rides in the front of the shaft, allowing the shaft to move fowards. I read this happened to VFX
    and it made it`s way past the rubber accordian cover?
    my driveshaft is completely covered!?...PR...

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP Took on water almost sank
    By Redspider in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-13-2009, 10:02 PM
  2. ski almost sank about an hour ago.
    By newskiier in forum 4-Tec Performance
    Replies: 35
    Last Post: 01-10-2009, 11:39 AM
  3. Exhaust gasket at transom...almost sank!!
    By roost5o in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 07-31-2008, 05:25 PM
  4. Ski almost sank!!!!
    By dcs191919 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-16-2007, 08:44 PM
  5. Almost sank my rxp today!
    By nitro rxp in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-20-2005, 09:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •