Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Pettee's Avatar
    Join Date
    Oct 2005
    Location
    Dover, DE... Again :(
    Posts
    1,814

    First successful ride

    Holy.
    Crap.

    Worth the fuss i had to go through with it, well worth it.

    Put it in, warmed it up, out to open area, 2WOT runs, back to dock(tide was going out, and even retrieving it i was standing in muck at the tires on the trailer)

    Cant wait till next weekend

    Gonna change the oil and filter again this week just for piece of mind, then this weekend its back out to somewhere other than the mudpit i went to today.


  2. #2
    Good to hear Pette! You needed that! ...PR...

  3. #3
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1
    About fucking time bro...


    GOOD FOR YOU

  4. #4
    Pettee's Avatar
    Join Date
    Oct 2005
    Location
    Dover, DE... Again :(
    Posts
    1,814
    hell yes i did. I just hope shit dont break, although if it does, its covered.

    RPMs seemed a little low on it tho?

    EDIT: The more i think about it, they were low, and it was only hitting 80kph(mines set to kph for some reason). I was just so excited it didnt sink i didnt think about it.

    Whats up with that?

  5. #5
    Pettee's Avatar
    Join Date
    Oct 2005
    Location
    Dover, DE... Again :(
    Posts
    1,814
    After talking with Shibby we determined something is wrong with it. Gonan change the oil(add some it seemed low) and try again on saturday, if its not that, dealer gets it, if its the cluth, it gets fixed and the ski sold.

  6. #6
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    good to hear u got it in the water, but i hope u can fix the problem by changing the oil instead of a new clutch. good luck man and keep us posted!

  7. #7
    Pettee's Avatar
    Join Date
    Oct 2005
    Location
    Dover, DE... Again :(
    Posts
    1,814
    Quote Originally Posted by rxpblast
    good to hear u got it in the water, but i hope u can fix the problem by changing the oil instead of a new clutch. good luck man and keep us posted!

    thanks man. Manual says that low oil can cause rpm loss and convert to limp mode, so im thinking thats what happened. Just bizarre cause the last one to change the oil was the dealer.

    Anyway, its getting drained and changed tomorrow.

  8. #8
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,360
    +1
    339
    Don't give up Pettee, once you get her squared away you will love it.

    You do have about the worst luck ever though- sorry about that .

  9. #9
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Pete Dont worrie dude just haul that damn thing down to sunny florida for ur vacation. Hang out with fine hot babes and u will be happy u got the ski. They will like all the power u got Come on down Bro.

    Adam Bomb

  10. #10
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    did you ever fix this low rpm issue? What was it?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ahhhhhhhhhhhhhhhhhhhhhhhhhhh.... first jetski ride of the new season
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 16
    Last Post: 05-13-2012, 06:25 PM
  2. First long ride on my new RXP-X.
    By sn-95 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-12-2010, 08:29 AM
  3. First REAL Ride of the new season
    By lakegastonrxp in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-17-2010, 03:23 PM
  4. First test ride results on RXP after new mods...
    By JAG in forum 4-Tec Performance
    Replies: 44
    Last Post: 12-24-2006, 08:30 PM
  5. First Offical Ride of 2006
    By 05RXPnoob in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-10-2006, 05:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •