Results 1 to 2 of 2
  1. #1

    Yamaha 96 RA1100 Cuts out at like 20+MPH

    Can anyone help me find out why my RA1100 just cuts out at like high speed (20MPH+)? Not exactly that speed but when you are running steady it will just shut off as if you hit the kill switch. Sometimes after this happens when I try to re-start it almost seems the battery is dead and the starter won't turn over at all. Then, a minute later it will start right up? This sounds electrical to me. Any ideas please??


  2. #2

    It did it again but this time had a burning smell

    It smelled like plastic burningn and there was some light smoke that went away after a minute. Can anyone help please????

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 05-31-2015, 06:58 AM
  2. 96 GTX cuts out at high RPM - rev limiter?
    By demne in forum 2-Stroke Performance
    Replies: 4
    Last Post: 05-30-2015, 08:48 PM
  3. 1997 Polaris 780 SLT (Cutting out at full throttle)
    By harleyfun1996 in forum Polaris Open Discussion
    Replies: 20
    Last Post: 03-24-2008, 01:02 PM
  4. 99 GTX Ltd Cutting out at high RPM
    By Picturemn2 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-28-2007, 04:55 PM
  5. Slx 780 Cutting Out At High Speeds
    By BRANDON in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-03-2007, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •