Results 1 to 5 of 5

Thread: SL650 Stalls!

  1. #1

    SL650 Stalls!

    I've been fixing up my ski all summer and finally thought I had it all ready for the water...turns out I was wrong.

    In the driveway on the trailer, it was starting up completely fine. I took it to the water, it started fine and I slowly took it out of the no wake zone. It was idling fine and everything. I begin to open it up and was at WOT for no more than 10 seconds at it just stalls out. I start it up again, same thing.

    I tried varying speeds and it would stall out after a certain amount of time but idling was usually alright. Each time it stalled it became harder and harder to crank it up, it seemed like it didn't wanna catch or something.

    Anybody had any problems like this or can offer me any suggestions? I've done everything and only thing I can think of is possibly the spark plugs? I got new ones but they might be wrong I have no idea.

    Originally it was thought that the electrical box had a problem but I bought a new electrical board because that seemed to be corroding. Other than that, I would love to hear anybody's feedback they might have. Thanks!

    1995 Polaris SL650 for reference


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Can we get a rundown on what you have done? Compression? Carbs cleaned? fuel pump upgrade?

  3. #3
    Quote Originally Posted by beerdart View Post
    Can we get a rundown on what you have done? Compression? Carbs cleaned? fuel pump upgrade?
    None of that stuff at all, all I've really done mechanically is install a new electrical board. Other than that, I've put new plugs in and that is about it.

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Check comperssion and rebuild the carbs.

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Adam, give me another call. I see what I can find.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sl650 stalling out
    By unyanhead in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-01-2007, 02:42 PM
  2. 92 to 93 SL650 TSBs
    By SeaLion in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 10-24-2006, 09:32 AM
  3. SL650 750 Impeller Pump Assembly
    By beerdart in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-15-2006, 10:27 PM
  4. SL650 with SL750 jugs?
    By delagem in forum Polaris PWC Performance
    Replies: 6
    Last Post: 09-12-2006, 07:29 PM
  5. sl650 Fuel pump
    By gerhand44 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-12-2006, 04:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •