Results 1 to 3 of 3
  1. #1
    Therock's Avatar
    Join Date
    Apr 2005
    Location
    Jacksonville,FL
    Posts
    170

    Is this drive shaft too far gone?

    I took my ski out the other day and I was cavitating very bad during take off. I took it out of the water and to find a bit of water inside my hull. While on the trailer I noticed it leaking water from the intake grate area (drive shaft exit point). I removed my drive shaft to replace the carbon ring and boot. This is what my drive shaft looked like. Is it salvagable or should i buy (267.00) a new one? Feedback pls..... Double click on top of the pics to get a better view...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC01076.JPG 
Views:	96 
Size:	1.29 MB 
ID:	35735   Click image for larger version. 

Name:	DSC01077.JPG 
Views:	116 
Size:	1.86 MB 
ID:	35736  


  2. #2

    Join Date
    Jun 2007
    Location
    Raleigh, NC
    Posts
    55
    That looks like quite a bit of wear to me. I just replaced a driveshaft on an 05 GTX that had more neglect issues than serious wear issues. the boat sat for several months on grass with a lot of moisture that just 'ate' at the driveshaft. There was alot of rust that 'tore' up o-rings and seals to enough to change it. There looks to be significant wear from the floating ring near the c clip groove or the bearing near the 'telltale' grove.
    Quote Originally Posted by Therock View Post
    I took my ski out the other day and I was cavitating very bad during take off. I took it out of the water and to find a bit of water inside my hull. While on the trailer I noticed it leaking water from the intake grate area (drive shaft exit point). I removed my drive shaft to replace the carbon ring and boot. This is what my drive shaft looked like. Is it salvagable or should i buy (267.00) a new one? Feedback pls..... Double click on top of the pics to get a better view...

  3. #3
    friebe1's Avatar
    Join Date
    Mar 2006
    Location
    Clovis, Ca
    Posts
    224
    Get the new shaft, the c-clip groove is too wide.
    You need to replace the collar and o-rings as well.
    Steve

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. is this the right o-ring for this drive shaft?
    By 1999-SLTX in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-17-2013, 05:15 PM
  2. Is this Drive Shaft correct?
    By svt killer in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-13-2013, 02:15 PM
  3. Need an expert advise on this drive shaft!!!
    By theking549 in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-17-2010, 07:58 PM
  4. Is my drive shaft seal bad?
    By Mr. Matrix in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-18-2010, 02:13 PM
  5. Is this WAY, WAY too much oil?
    By ZOMGVTEK in forum Polaris Open Discussion
    Replies: 2
    Last Post: 10-21-2009, 09:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •