Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1

    need help with a 97 sltx

    hi all,i need some help with my ski and have no polaris dealer around here anymore.i think i have some sort of electrical problem.the ski starts and runs but if you try and rev it up it bogs.carbs and lines have been cleaned and cleared.gas has been drained and new gas put in.

    when in the water the ski will run (sluggishly) up to about 20mph or so,trying to give it more gas and it bucks,doesnt backfire.

    i have spark at all 3 plugs,fuel in all 3 carbs,and had a compression test done.

    i dont know if i have weak spark,i know i have good fuel,clean carbs,and new plugs.good compression.

    any idea's?

    samantha


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Does the MFD work? Are there any warnings on it? Sounds like it is in limp mode.

  3. #3
    Quote Originally Posted by axgrider73 View Post
    Does the MFD work? Are there any warnings on it? Sounds like it is in limp mode.

    actually now that you say that,the display does work but shows no rpms,also acts a bit weird in that it will sometimes flash oil,i think once even flashed hot for a sec,cant really be 100 percent sure on that as it was very quick,so maybe your on to something there.can it be reset?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Does the Impeller spin freely?

  5. #5
    yes its spinning freely,small space evenly in between the impellor and the pump,all the way around.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Have the carbs been gone thru? Have you tested the stator?

  7. #7
    Banned User
    Join Date
    Aug 2006
    Posts
    1,236
    Do a compression check.
    It should be around 130psi.

  8. #8
    Quote Originally Posted by beerdart View Post
    Have the carbs been gone thru? Have you tested the stator?
    yes the carbs have been gone thru,no the stator has not been tested,how would i test the stator?is it something thats easy to do or dealer only?

  9. #9
    Quote Originally Posted by wetherby View Post
    Do a compression check.
    It should be around 130psi.

    yes compression is good 130,125,130.front to back.

  10. #10
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,571
    +1
    35
    Samantha,you mentioned cleaning,clearing the fuel lines/carbs. Was there alot of debris in lines or carbs? Could they be dirty again? Now that these PWC are older,some fuel lines deteriate(fall apart on inside)

    Testing the stator isn't hard.The test and specs are in the tech section/domestic ignition diagnosis. there also is a Polaris shop manuel posted.

    The posibility of the limp mode being activated because of a warning(oil/temp).I've heard of a certain wire to disconnect,to eliminate the limp mode,sorry I don't remember which one.Hopefully someone will join in with that info/or try a search.
    Last edited by casey67; 08-20-2007 at 09:54 PM.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I need help with Polaris SLTX 1996
    By Dimon in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-02-2011, 05:46 PM
  2. Need Help With 97 Venture
    By Studio143 in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 10-18-2010, 12:01 AM
  3. Need help with 99' SLTX
    By gt_maynard in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-15-2010, 11:13 PM
  4. Need some help with my 97 XP
    By midnight08 in forum 2-Stroke Performance
    Replies: 7
    Last Post: 05-27-2009, 07:51 PM
  5. NEED HELP with the xp 97
    By valk in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-28-2008, 05:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •