Results 1 to 7 of 7

Thread: Speedo fix?

  1. #1
    I like 'e way yew tawlk Ric's Avatar
    Join Date
    Aug 2007
    Location
    Blue Ridge, GA
    Posts
    44

    Speedo fix?

    Hey guys, the speedo on my STX-R don't work. Not that they're right ever, but it'd be nice to have a ballpark estimate, so any idears on how to get it working again???


  2. #2
    PhilnEdee's Avatar
    Join Date
    Aug 2007
    Location
    Union Grove, Alabama
    Posts
    477
    Quote Originally Posted by Ric View Post
    Hey guys, the speedo on my STX-R don't work. Not that they're right ever, but it'd be nice to have a ballpark estimate, so any idears on how to get it working again???

    Is it intact? Is the wheel gummed up? Cables attached on both ends...things like that?

  3. #3
    I like 'e way yew tawlk Ric's Avatar
    Join Date
    Aug 2007
    Location
    Blue Ridge, GA
    Posts
    44
    All's freely moving, and from what I gather, everything is still hooked up. It actually flashed 59 and 63 the last time I was on the lake and then quit.

  4. #4
    I like 'e way yew tawlk Ric's Avatar
    Join Date
    Aug 2007
    Location
    Blue Ridge, GA
    Posts
    44
    Anyone have a clue???

  5. #5
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    This is out of the Ultra manual but I would bet they are all the same. Maybe give it a look.

    Let us know what you find.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	kawispeedo.JPG 
Views:	54 
Size:	70.5 KB 
ID:	36019  

  6. #6
    I like 'e way yew tawlk Ric's Avatar
    Join Date
    Aug 2007
    Location
    Blue Ridge, GA
    Posts
    44
    I'd imagine it's the same unit. Is it showing the wiring out of the info display???

    Thanks for pointing me where to check, will git'r dun tomorrow.

  7. #7
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    Ric,

    That manual is in the tech section if you would like to take a peek at it.

    Good luck,

    Rob

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Maybe a speedo fix??
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-28-2007, 07:59 AM
  2. Ultra 250 Speedo fix
    By MrSxy4Ever in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 05-01-2007, 09:17 AM
  3. Fixing bottom of hull....
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-20-2005, 03:37 PM
  4. 76.4 got ecu /problem fixed thanks to this forum
    By peter in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-11-2005, 01:32 PM
  5. RXP Speedo Questions
    By tchies in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-21-2005, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •