Results 1 to 5 of 5
  1. #1
    RXP'in in MI's Avatar
    Join Date
    Jan 2006
    Location
    Grand Rapids, MI
    Posts
    184

    '04 oil pressure switch failure

    In '04 there was a common occurring problem with oil pressure switches failing. What were the symptons when one failed? Was it more common for the front one to fail or the one under the TB?
    When I initially put my RXP in the water, after a warm up, it will flash "OIL" on the display when throttling up and it goes into a limp mode, sputters and spats if rpms get above 3000-4000 RPMs. I then take the laynard off/on and restart it a couple times before it clears up and runs fine the rest of the day. It does this inconsistently, as sometimes I put it in the water and it takes right off. Other times I get the sputter&spat syndrome. Oil level is @ halfway between the bends. Any suggestions or recommendations? Other forum members experienced this?


  2. #2
    Quote Originally Posted by RXP'in in MI View Post
    In '04 there was a common occurring problem with oil pressure switches failing. What were the symptons when one failed? Was it more common for the front one to fail or the one under the TB?
    When I initially put my RXP in the water, after a warm up, it will flash "OIL" on the display when throttling up and it goes into a limp mode, sputters and spats if rpms get above 3000-4000 RPMs. I then take the laynard off/on and restart it a couple times before it clears up and runs fine the rest of the day. It does this inconsistently, as sometimes I put it in the water and it takes right off. Other times I get the sputter&spat syndrome. Oil level is @ halfway between the bends. Any suggestions or recommendations? Other forum members experienced this?
    Hey bro! Dude, didn`t that freak you out when it first happened? yeah, it`s the limp mode and rev limiter so you don`t do any damage, me thinks. I had that happen to me, it was an incorrectly installed oil pressure regulator. anyways, replace those 2 sensors, I think they are like $25 a piece. and maybe you want to check the oil pressure at the oil pressure switch port or the port on the head just below and to the right of the coolant hose at the head...check pressure to verify everything is good, cold and hot...
    you didn`t have SC ceramic failure did you?...PR...
    Last edited by Pale Rider; 08-22-2007 at 04:08 PM.

  3. #3
    RXP'in in MI's Avatar
    Join Date
    Jan 2006
    Location
    Grand Rapids, MI
    Posts
    184
    PR, yes it was an eye opener the first time the limp mode occurred and guage displayed "OIL". Right away you get visions of a major engine catastrophe. Definitely grabs your attention.
    No to ceramic washer failure. Replaced them after year 1, had about 25 hrs on the RXP. Did the Sea Doo Centre steel washers as a preventative maintenance measure. Sure glad I did the replacement.

  4. #4
    Quote Originally Posted by RXP'in in MI View Post
    PR, yes it was an eye opener the first time the limp mode occurred and guage displayed "OIL". Right away you get visions of a major engine catastrophe. Definitely grabs your attention.
    No to ceramic washer failure. Replaced them after year 1, had about 25 hrs on the RXP. Did the Sea Doo Centre steel washers as a preventative maintenance measure. Sure glad I did the replacement.
    I would go ahead and change out those sensors, prolly set a code in the ecu, should have that checked or editted, and maybe Shibby can add or correct something said here...PR...

  5. #5
    Gotta love this sport! 05Limited's Avatar
    Join Date
    Apr 2005
    Location
    Stockton, CA
    Posts
    2,678
    +1
    3
    Quote Originally Posted by RXP'in in MI View Post
    ... Definitely grabs your attention....
    Yes it does...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pressure switch problem
    By Squirl in forum Honda How To & FAQs
    Replies: 24
    Last Post: 07-15-2012, 09:06 PM
  2. oil pressure switch
    By ed kramar in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-31-2012, 07:41 PM
  3. Oil Pressure Switch
    By Scooter in forum Honda How To & FAQs
    Replies: 6
    Last Post: 07-18-2010, 02:04 PM
  4. Oil Pressure Switch Thread Size ?
    By PWCGUY in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-14-2010, 09:52 AM
  5. Kawi 12F Oil Pressure Switch Issue
    By kauferlie in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-03-2006, 05:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •