Results 1 to 10 of 10

Thread: sc slippage!!

  1. #1

    sc slippage!!

    how do i fix or adjust the sc so it doesnt slip as much? only getting
    4 lbs of boost dont know what else it could be?


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,626
    +1
    806
    A supercharger re-build is in order depending on how many hours are on it. I'm not sure of the make-up of the 03 s/c but the 04-07 skis have spring washers for $25 you can add to get the tension back..

  3. #3
    i just bought the ski 2 weeks ago, the tech that works at the dealer
    said they just rebuilt the sc and pump, motor mounts and some other things.

  4. #4
    Quote Originally Posted by FL03GTX View Post
    i just bought the ski 2 weeks ago, the tech that works at the dealer
    said they just rebuilt the sc and pump, motor mounts and some other things.
    what type of gauge do you have? what did they exactly do to the SC? did they upgrade to an 06 kit? is there ceramics in there now?
    try a dif gauge if you can...PR...

  5. #5
    autometer gauge. they used a "riva rebuild kit" on the sc.

  6. #6
    NCNismo32's Avatar
    Join Date
    Jan 2007
    Location
    Fayetteville, NC
    Posts
    94
    PR what is the specs for the 03 as far as lbs of boost go??? p.s. I almost blew mine up this weekend draining the oil out cause of lost rpms but I finally found the sweet spot and got her running 63.5-64 in 90-95 degree temps. Not fun hearing the difference in sound of a SC and engine w/ low oil in it though only ran it for a few minutes that way.

  7. #7
    2017 RXT-X 300 zone 5's Avatar
    Join Date
    Jun 2007
    Location
    Lake Luzerne, NY
    Posts
    589
    +1
    8
    Quote Originally Posted by FL03GTX View Post
    how do i fix or adjust the sc so it doesnt slip as much? only getting
    4 lbs of boost dont know what else it could be?
    What RPM is it turning? Could just be that you ar enot getting a correct read on the Boost gauge.

  8. #8
    54-55 mph @ 71-7200 rpm with half tank of gas.
    56-58 mph @ 72-7360 rpm with no gas and 165 lb rider.
    using stock gauges not gps. using 93 octane fron chevron.
    Last edited by FL03GTX; 08-23-2007 at 06:37 AM. Reason: missed something

  9. #9
    skipSC's Avatar
    Join Date
    Feb 2006
    Location
    Stuart, Fl.
    Posts
    1,445
    +1
    171
    Your rpms are a little low, recheck the s/c to t/b hose clamps to make sure they are tight and no leaks. And make sure your oil level is not too high and check your wear ring.

  10. #10
    they just put a new prop & wear ring in when they did all the other stuff.
    and oil is in the middle.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP SC Clutch Slippage too high?
    By ncdoo in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 01-14-2012, 09:41 PM
  2. SC slippage or drivetrain?
    By RayinJapan in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-13-2011, 01:49 AM
  3. Is this also sign of SC slippage?
    By VenomRXP in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 05-12-2008, 08:45 PM
  4. SC clutch slippage...
    By Alaska05RXT in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-20-2006, 01:24 AM
  5. SC impeller
    By shhr in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-02-2005, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •