Results 1 to 8 of 8
  1. #1
    jtmoney33's Avatar
    Join Date
    Apr 2007
    Location
    Belleville MI
    Posts
    106

    07 rxp need help

    I have a 07 rxp with 21 hrs on it. I have very very bad cavatation (end up getting the rev limiter) when I take off until I get up and going. When the ski was gps'd the best run was only 54mphs with a nice flat surface. RPM's are normal at 8100 to 8150, is this a wear ring problem or what... someone please help...


  2. #2
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Sounds like SOME type of pump problem. Maybe something is broken, or missing, or clogged. I'd get the ol' handy dandy flashlight out and start looking around under there.

  3. #3
    jtmoney33's Avatar
    Join Date
    Apr 2007
    Location
    Belleville MI
    Posts
    106
    alright thanks for the reply and help... now would this be a warrenty work type or am I just better off working on it myself???

  4. #4
    Scotty's Avatar
    Join Date
    Mar 2007
    Location
    Cropwell,Al
    Posts
    302
    +1
    4
    Quote Originally Posted by jtmoney33 View Post
    alright thanks for the reply and help... now would this be a warrenty work type or am I just better off working on it myself???
    More than likely something is in or went through your pump like rocks or wood. If something is broke or missing like Mark said it was more than likely caused by something going through your pump. There is a slim change warranty would do anything.

  5. #5
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Do this yourself. More than likely, you have something stuck in the pump or wear ring damage from something that went through the pump. If that is the case, it's not a warranty issue. Plus, the dealer will take much longer to fix it than you will. If you do not know how, check out this link:

    http://greenhulk.net/forums/showthread.php?t=536

  6. #6
    jtmoney33's Avatar
    Join Date
    Apr 2007
    Location
    Belleville MI
    Posts
    106
    thanks for all your help guys... hopefully I can check it all out tomorrow if the weather is good

  7. #7
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    Also the dealer will charge you out the ying yang for debris. If your wear ring is gone ya should go ahead and make plans on a ss wear ring I went through 3 of em b/f I woke up the last one only lasted 5 hrs.

  8. #8
    SPECIAL332's Avatar
    Join Date
    Aug 2007
    Location
    BULLHEAD CITY, AZ
    Posts
    77
    Yes, Definitely Get The S/S Wear Ring. I Went Through 2 Factory Ones With Only 12 Hours On! They Are Pricey, But Well Worth It.


    2007 Rxp
    Riva Stage I

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Chipped gelcoat in 07 RXT-Need help!
    By steviey2493 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-18-2010, 09:10 PM
  2. Newbie with a 05 rxp needing help!
    By PWC Newbie in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-13-2009, 12:22 AM
  3. Flood Damaged RXP...need help!!
    By idohcvtecexi in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 07-05-2009, 02:25 AM
  4. 04 RXP need help
    By seadawg in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-06-2008, 08:41 PM
  5. 07 RXP !!!!need help
    By psi_2_high in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-09-2007, 10:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •