Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Thumbs down How do I find my boost leak?

    I just added an XS intercooler. Hit the water for the first time and could only run 55 mph at 6800 RPM's.

    Would love any suggestions on where to start or any trick you guys may have. Thanks in advance.


  2. #2
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Do you have a boost gauge ? If so how much boost do you have ?The leak I had was around the stock IC blockoff plate, that needs plenty of silicone.

  3. #3
    Quote Originally Posted by DaveC View Post
    Do you have a boost gauge ? If so how much boost do you have ?The leak I had was around the stock IC blockoff plate, that needs plenty of silicone.
    how did you find the leak around the IC block -off ?
    what were your symptoms? low rpm?...PR...

  4. #4
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    My RPMs was low as was the boost. I had already cleaned and re-installed the pipes to the intercooler. Jerry advised to check the blockoff. When I had installed it the first time I used a fine bead of silicone. On the second install I used a bead about the size of a pencil where the blockoff flange mates to the intake. Applied even more to the blockoff clamp. That sealed it up, boost and RPMs improved with no other changes.

  5. #5
    Quote Originally Posted by DaveC View Post
    My RPMs was low as was the boost. I had already cleaned and re-installed the pipes to the intercooler. Jerry advised to check the blockoff. When I had installed it the first time I used a fine bead of silicone. On the second install I used a bead about the size of a pencil where the blockoff flange mates to the intake. Applied even more to the blockoff clamp. That sealed it up, boost and RPMs improved with no other changes.
    what was your RPM`s and boost numbers?
    I did the same thing applied silicone, thought I had enough bc I didn`t want to make a big mess. when I popped it in there none smooshed out.
    I have a stock SC wheel in there, shouldn`t the "O" ring seal it enough?...PR...

  6. #6
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    From memory I was turning just over 7600 RPMs and almost 8 PSI boost(at that time RR/SC wheel).
    After the silicone job I was back to 8100 RPMs and 9.3-9.4 boost.

    I had silicone come out, actually alot came out. Then I installed the clamp with even more silicone it it. Cleaned it up a little and was good to go.
    The O-ring is not enough. I was thinking that also when I installed the blockoff the first time and used very little silicone.

  7. #7
    Quote Originally Posted by DaveC View Post
    From memory I was turning just over 7600 RPMs and almost 8 PSI boost(at that time RR/SC wheel).
    After the silicone job I was back to 8100 RPMs and 9.3-9.4 boost.

    I had silicone come out, actually alot came out. Then I installed the clamp with even more silicone it it. Cleaned it up a little and was good to go.
    The O-ring is not enough. I was thinking that also when I installed the blockoff the first time and used very little silicone.
    ok, thanks, I have to find a way to test it before I start prying the block-off out of there...PR...

  8. #8
    sleeplessnMS's Avatar
    Join Date
    Mar 2006
    Location
    Waveland,MS
    Posts
    1,943
    could only run 55 mph at 6800 RPM's.
    If you are losing that much boostr ya should be able to take seat off whuile in the water riding and hear that leak

  9. #9
    Quote Originally Posted by Dark_viper42 View Post
    I just added an XS intercooler. Hit the water for the first time and could only run 55 mph at 6800 RPM's.

    Would love any suggestions on where to start or any trick you guys may have. Thanks in advance.
    Did you seal your stock IC blockoff with a FAT bead of silicone?
    Did you spray windex in your couplers for a better seal on your IC pipes?
    Did you pressure check your IC before installing it?
    Did you do anything else besides installing the IC?

    What RPM were you turning before installing the IC?

  10. #10
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    Quote Originally Posted by sleeplessnMS View Post
    If you are losing that much boostr ya should be able to take seat off whuile in the water riding and hear that leak
    Maybe also spray 409 on the hose connections and the block off while running to see where it might bubble up and find the leak.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do i find a water leak?
    By TyCast in forum Polaris Open Discussion
    Replies: 12
    Last Post: 10-23-2016, 06:15 AM
  2. How do I find out which parts will fit my ski?
    By ppkarnezis in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 02-07-2009, 10:28 AM
  3. how do i install a boost gauge on a 03 gtx?
    By FL03GTX in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-20-2007, 03:00 PM
  4. how do i install a boost gauge on a 03 gtx?
    By FL03GTX in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-20-2007, 02:26 PM
  5. How Do I Lube My Throttle Body Port The Correct Way?
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-26-2007, 10:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •