Results 1 to 5 of 5

Thread: Help?

  1. #1
    Dont judge me...
    Join Date
    Jul 2006
    Location
    FLORIDA
    Posts
    610

    Help?

    Ok, so i put the riva valvetrain in and the back cylinder air compressor did not come on alot, the middle cylinder came on a lot more often, and then the front cylinder came on about like the middle one, BUT had a wonderful sound of bubbling and gurgling....now the ski was on my trailer and there is a downward angle towards the front (don't know if that matters). My ecu is at riva right now, when it gets back i will be doing a compression test. any thoughts on what it could be or what? thanks


  2. #2
    friebe1's Avatar
    Join Date
    Mar 2006
    Location
    Clovis, Ca
    Posts
    224
    Dont stress just yet, if the ski has been sitting a while since it has run and or it is cold they might not all act the same.
    After you get the ecu back take it out and ride it, get it up to operating temps and then do a compression test. If more than 10 percent difference then have a leak down test done. If less than 10 percent , ride it and enjoy it!
    Steve

  3. #3
    GOTTA PAY TO PLAY!!! rocko672's Avatar
    Join Date
    Sep 2006
    Location
    Lutcher, La.
    Posts
    260
    that is normal....i did mine and i did jerry's 07' and both time each cylinder sounded different cause of where each piston is when you put the pressure on, from what i've been told....... my $.02

  4. #4
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    someone explain in detail and step by step how to do a compression test. every time i try the gauge just pops back and forth and never registers anything for compression. im lost.

  5. #5
    friebe1's Avatar
    Join Date
    Mar 2006
    Location
    Clovis, Ca
    Posts
    224
    Steve, make sure you have a schrader valve in the hose.
    It sounds like it might not be there or leaking badly.
    Some hoses dont have the valve, it looks just like a valve core but holds more pressure. If you can blow through the hose in both directions you need to get the valve or a hose with a valve.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •