Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22

Thread: Hi All

  1. #1

    Hi All

    I am new here...........and new to the pwc world. I just got my first ski its a 97 polaris 1050.......was FREE. I was told it had a bad sleave and needed piston rings.......that was a understatment. The piston closest to the front of the ski had zero compression so I pulled the head and wow not much a piston left at all. The head looks like it was shot with a shotgun.

    Is it worth just fixing the one piston and head? At what point does it make more sence to replace the whole motor?

    I stuck a magnut down in the crank case and pulled back parts of the piston in ittibitti shavings..............I am guessing this is not good. Mabee thats my answer to either a complete rebuild or a new buy ehhh

    Can I pull the motor without pulling the drive pump?
    Last edited by StLRivRat; 08-26-2007 at 02:32 PM. Reason: more questions


  2. #2
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to the forum

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quote Originally Posted by StLRivRat View Post
    I am new here...........and new to the pwc world. I just got my first ski its a 97 polaris 1050.......was FREE. I was told it had a bad sleave and needed piston rings.......that was a understatment. The piston closest to the front of the ski had zero compression so I pulled the head and wow not much a piston left at all. The head looks like it was shot with a shotgun.

    Is it worth just fixing the one piston and head? Yes if the crank is good At what point does it make more sence to replace the whole motor?

    I stuck a magnut down in the crank case and pulled back parts of the piston in ittibitti shavings..............I am guessing this is not good. Mabee thats my answer to either a complete rebuild or a new buy ehhh you need to get all the stuff out of the crankcase.

    Can I pull the motor without pulling the drive pump?
    No you need to pull the pump and drive sahft.



    Pics are good.






  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the Hulk. Pistons are made of aluminum or some sort of alloy. The pieces you pulled out with a magnet are either piston rings, or part of the crank? You'rer gonna need to disassemble the engine most likely to see if it's salvagable, and the pump does need to come off the remove the driveshaft from the engine.

  5. #5

    Removing pump

    OK I am removing the pump. I have 4 nuts off from the outside and the boots all loose. Stearing and reverse and hoses are off. Should this thing just come off now?

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Yes it might take a 2X4 in the ride plate and wiggle.

  7. #7
    It is loose as hell but it wont come off. Do I need to take the aft end of the pump off first or should the whole thing just slide out? I am searching this site for some instructions while I wait for a answer.

  8. #8
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    It should just slide right off. When I took mine off, it felt real loose, but had permatex holding it together at the hull. Crawl under there and see if it is hung up on something. Should come off easy enough.

  9. #9
    Just so I dont break anything is there anything that hooks to the pump under the ride plate? I see the pump has 2 halfs. Is there anyhting in there i need to take apart?


    THANX for all your guys time I am reading as many posts as i can, so much now I have info overload.

  10. #10

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,703
    +1
    109
    did you pull the four long bolts or the four nuts that hold it to the hull ???
    you want the four long bolts not the four nuts other wise you have to pull the hoses off from inside the hull

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi All, Im the new guy w/a question
    By Proflow in forum 2-Stroke Performance
    Replies: 18
    Last Post: 04-25-2008, 09:38 AM
  2. hi all..
    By levonhelmet in forum Open Discussion
    Replies: 12
    Last Post: 01-02-2007, 12:35 AM
  3. Hi all , New onboard
    By BOOSTED in forum 4-Tec Performance
    Replies: 33
    Last Post: 10-30-2006, 02:47 AM
  4. Hi all, New to the forum, all the way from UK
    By Mark-UK in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-21-2006, 10:00 AM
  5. Hi all.. New here..
    By Saladbar in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-14-2005, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •