Results 1 to 2 of 2
  1. #1
    rob2337's Avatar
    Join Date
    Jun 2007
    Montréal, Québec Canada

    94 Sl750 Grinding Noise

    Recently my 94 750 has developed some sort of intermittent grinding noise. It usually happens during acceleration, and really echoes through out the whole hull. It sounds as if the hull was scrapping against the rocks or something. It started a week ago, and now it seems to be getting worse. It only occurs at certain RPM ranges, and then goes away. I have a new coupler and driveshaft in it. Could it be the pump bearings?

  2. #2
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    SE Kansas
    Ouch, tough call. I would say that it is most likely a bearing, but as to which one???? The pump bearings are cheap. I would start there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. R12X making grinding noise
    By HondaR12x400ex in forum Honda Performance
    Replies: 6
    Last Post: 06-10-2009, 09:33 AM
  2. Grinding noise left hand turns
    By Burkma in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 03-08-2008, 05:45 PM
  3. Extremely rough engine yesterday- grinding noise
    By vidbuster in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-26-2007, 11:26 AM
  4. Help diagnosing a grinding noise? Z
    By ZMANN in forum Polaris Open Discussion
    Replies: 12
    Last Post: 10-10-2006, 11:02 PM
  5. no drive and bad grinding noise
    By timbo in forum 4-Tec Performance
    Replies: 19
    Last Post: 01-27-2006, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts