Results 1 to 7 of 7

Thread: question !??

  1. #1

    question !??

    my fi light came on when i got stuck in mude i was reving it a lil bit ... did i cause any damage? it turned off when i was at deeper water


  2. #2
    monster's Avatar
    Join Date
    Mar 2007
    Location
    sandy eggo, yo!
    Posts
    71
    Stuck in mud?

  3. #3
    Don't ever rev or run the engine in less than two feet of water. You've got basically a 250HP pump that will suck up fist sized rocks if they could get through. Mud will tear up the prop and block cooling lines. Might want to read your owners manual completely before riding again (especially the riding tips section).

  4. #4
    PhilnEdee's Avatar
    Join Date
    Aug 2007
    Location
    Union Grove, Alabama
    Posts
    477
    Quote Originally Posted by tom4416 View Post
    Don't ever rev or run the engine in less than two feet of water. You've got basically a 250HP pump that will suck up fist sized rocks if they could get through. Mud will tear up the prop and block cooling lines. Might want to read your owners manual completely before riding again (especially the riding tips section).
    Yes...and stay outta that "mude".

  5. #5
    believe me i know .. but this was a freak act of nature i was so stuck in the middle of this river and picture being stuck for 300 yards 1 ft and half mud !! i ran her and push here off and on i had no choice other than to sit and wait for water to rise .... what i am saying is the fi light came on when the over heat light came on a biut after i shut it off right after th eover heat light came on ... what would have caused the fi light to come on

  6. #6
    Fairlanex
    Join Date
    Aug 2007
    Location
    Cairns, Australia Summer all year round!
    Posts
    57

    stuck in the MUDE

    Hey I did the same thing in an inlet. Despite knowing all too well not to run in shallow water I had to do the same as you did .I tried walk/dragging it out but I was concerned about nasties that might bite (crocs) sting (jelly fish) or otherwise kill me (stonefish or stingray) Cost me a prop to get back. The alternative was a loooong wait. I would think if the F1 doesn't come on again when you are running, then don't worry about it especially if it's performing OK.

  7. #7
    [quote=fairlanex;394969]... I was concerned about nasties that might bite (crocs) sting (jelly fish) or otherwise kill me (stonefish or stingray) .../quote]

    Dang you Aussies are a tough bunch! And you didnt even mention the sharks! I dont think Id PWC over there without a wetsuit, under a dry suit, under chain mail with a couple of bang sticks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •