Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26

    97 XP Full of water!! Bad carbon ring??

    My buddy has a 97 XP that looks minty clean that he just picked up for next to nothing!!! He rode it for 2 hours and than had to drain water out of it for 20 minutes! Filled up to the center point on the engine... I pulled the pump off and tried to remove the retainer on the driveshaft (silver top hat looking thing) Im pretty sure its the carbon ring thats bad and causing a leak????? Im not familiar with seadoo's as I ride a gpr but Id really like to help my friend out.... Any sugestions on how to get this shaft out??? And how is it suposed to be set up??? Im begging for help!!!!


  2. #2
    indycar's Avatar
    Join Date
    Aug 2007
    Location
    Muncie, IN
    Posts
    21
    First off, do you know where it's leaking for sure?

    If not, put it in the water and run the engine with the seat off and find the source of the leak (on a lift with the intake grate in the water). Often leaks occur around the exhaust pipe and manifold.

  3. #3
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    I dont know for sure that its leaking from the carbon ring... However when my shop lite is in the back of the hull with the jet pump off I can see the light through the place where the shaft goes through the hull... The ring seems to be much larger than the diameter of the shaft... and yes I know the shaft is tappered and such.... If i scratch my head anymore im going to be missing hair

  4. #4
    indycar's Avatar
    Join Date
    Aug 2007
    Location
    Muncie, IN
    Posts
    21
    well, first you need to determine where its leaking. Is it a hull leak or an engine leak? It may well need a ring, but right now your kinda shooting in the dark

  5. #5
    BigT's Avatar
    Join Date
    Nov 2006
    Location
    Texas
    Posts
    105
    Since your not at the lake, you could fill the hull with water and see where it leaks out. IF your close to the lake, just back it in with the seat off, and see if its leaking around the carbon ring, you will see it. Alot of times you can loosen the accordian boot clamp, pull the boot tighter forwards and tighten it back up. Also check your rubber boot on the thru hull fitting for the vts, could be leaking there.
    If its not leaking around the ride shoe and plate, or anywhere around the rear of the hull, then start it up and look for hose leaks. I take it that wasnt overheating? Thats a good sign lol. Check all your hoses, especially the 3 or 4 inch long by 3 inch that connects the pipes and waterbox. Good luck...BigT

  6. #6
    JayZ's Avatar
    Join Date
    Feb 2006
    Location
    mississauga, ontario
    Posts
    407
    +1
    1
    the seat doesn't need to come off of a 97xp to check the carbon ring.

    it is more than likely the carbon ring. to remove the driveshaft, pull the pump, slide the metal collar on the driveshaft towards the back of the boat. there should be a metal 'c' clip on the driveshaft. pop off the 'c' clip and pull the drive shaft out. the carbon ring will be larger than the diameter of the shaft, but check the rubber boot that it is clamped to.

  7. #7
    BigT's Avatar
    Join Date
    Nov 2006
    Location
    Texas
    Posts
    105
    LOL, thanks for clarifying that bout the seat. I wasnt even thinking bout it being a 97 XP, I'm so used to working on my gsx's. matter of fact never had the carbon ring go bad on either XP I owned, only the gsx....BigT

  8. #8
    "Hustler" Inkaddict's Avatar
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    4,712
    +1
    26
    Ok so i slid the top hat looking thing back and got the shaft out... Thank you for telling me to slide that back... I almost broke out the torch!!! I took the shaft and carbon ring out... the shaft has slight pitting as does the carbon ring on he inner diameter... Do they both need to be changed??? Thanks again so far for your help guys! Thats why I love this forum!!

  9. #9
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by Inkaddict View Post
    Ok so i slid the top hat looking thing back and got the shaft out... Thank you for telling me to slide that back... I almost broke out the torch!!! I took the shaft and carbon ring out... the shaft has slight pitting as does the carbon ring on he inner diameter... Do they both need to be changed??? Thanks again so far for your help guys! Thats why I love this forum!!
    Did you check to make sure he has both bailer tubes in his venturi nozzle? If one fell out it will pump water into his hull instead of suck it out. Also check the accordian rubber boot. Pull it off, and closely inspect it for splits. 90% of the time they are at the bottom and only leaks when going wot.

    As far as the SS ring and carbon ring...if the SS ring is pitted, it is bad, because someone ran it on the hose without dribbling water on the ring and burnt it up. A common mistake...no SD manual tells you to keep the carbon ring wet!

  10. #10
    Blackhardt's Avatar
    Join Date
    Aug 2006
    Location
    Shiloh NC
    Posts
    133
    96 XPSS, that is a very good point that I had never thought about while running mine on the hose. Thanks for that little tibbit. Karl

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Possible sighs of bad carbon ring or not?
    By dooit260 in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 07-28-2015, 07:28 AM
  2. My maiden voyage left me with a hull full of water. (96 XP)
    By JJLee138 in forum Sea Doo Open Discussion
    Replies: 29
    Last Post: 03-20-2013, 12:32 AM
  3. 97 xp taking on water/wear ring
    By diesel04 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-02-2010, 05:41 PM
  4. video of my 97 xp 787 on water & trailer. what is wrong with it?
    By djpeetur in forum 2-Stroke Performance
    Replies: 7
    Last Post: 05-11-2010, 06:28 PM
  5. My RXP full of water..please help
    By jbeast in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-22-2007, 06:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •