Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Jun 2006
    Location
    Richmond, Va
    Posts
    240

    Help Troubleshooting 06 RXP

    I have had this problem twice that once I get to the water, put on the key I click on the start button and I can hear the starter clicking but it won't turn over. After trying several times it eventually starts and if I turn it off during the run forthe day it starts right up. Does this sounds like a battery problem? Anyone else had this proboem before? I just have not had the time to troubleshoot the ski and wanted to see if someone can chime in that has seen this before.


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    could be....I think Shibby often mentins the starter solenoid as a problem too

    edit: my money's on the battery though. do you use a battery tender?
    Last edited by The Bandit; 08-30-2007 at 10:53 AM.

  3. #3

    Join Date
    Jun 2006
    Location
    Richmond, Va
    Posts
    240
    No I don't use one. I wonder why it will start after many tries. I would assume if the battery is dead it would not start.

  4. #4
    vidbuster's Avatar
    Join Date
    Jan 2007
    Location
    Suburban Wasteland, CA
    Posts
    221
    +1
    1
    This happends to me. I also have an 06 rxp with the stock battery. I've heard its good just to get a new battery after two years anyways, so next Spring I'll get a new one.

    By the way, what would be a great aftermarket battery, should I just go with the same or the Riva?? The Riva one is more than twice as much at $129


  5. #5
    mstennes's Avatar
    Join Date
    Jul 2006
    Location
    On the Columbia River above a Dam
    Posts
    843
    +1
    1
    Sounds like the battery is low, and you get lucky. After you ride awhile it gets charged up, but then looses its charge after it sits.

  6. #6
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Check your bat voltage. It should be 12.6 if fully charged. If not then that may be the prob.

  7. #7

    Join Date
    Jun 2006
    Location
    Richmond, Va
    Posts
    240
    Appreciate the tips. I am off tomorrow so I will check it out.

  8. #8
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    It is the starter solenoid, make no mistake about it.
    No disrespect to the other replies, but they are wrong...
    Go get a new solenoid for 38 bucks and be done with it.

  9. #9
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    Quote Originally Posted by RXP Steve View Post
    It is the starter solenoid, make no mistake about it.
    No disrespect to the other replies, but they are wrong...
    Go get a new solenoid for 38 bucks and be done with it.
    the only disrespect I see is pointing out correct way I spelled solenoid.....me=good guy!!!!
    Last edited by The Bandit; 08-30-2007 at 10:54 AM.

  10. #10
    vidbuster's Avatar
    Join Date
    Jan 2007
    Location
    Suburban Wasteland, CA
    Posts
    221
    +1
    1
    Quote Originally Posted by RXP Steve View Post
    It is the starter solenoid, make no mistake about it.
    No disrespect to the other replies, but they are wrong...
    Go get a new solenoid for 38 bucks and be done with it.
    Regardless I'm buying a new battery next year, should I get the Riva one?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP WITH 06 RXP please
    By ALM MOTOR SPORTS in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-02-2008, 09:31 PM
  2. 06 rxp water in cylinders and oil help please
    By blue5speed in forum 4-Tec Performance
    Replies: 7
    Last Post: 01-04-2008, 09:45 AM
  3. RPM help for 06 RXP
    By SeaDooers in forum 4-Tec Performance
    Replies: 11
    Last Post: 10-04-2007, 11:06 AM
  4. Need Help with HEAD removal 06 RXP
    By sr71bb in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-25-2006, 02:06 PM
  5. whats next for my 06 rxp? neep help!
    By beachboy66 in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-12-2006, 08:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •