Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34
  1. #1
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1

    Odd Wear Ring Problem

    I was removing my prop today and found that the wear ring would come out all by itself??

    It would actually spin in the pump very easily by turning the prop.

    Has anyone ever noticed this?

    Pump is headed to Scat tomorrow, do they set screw the SS ring in place?

    Thank

    David


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    No, the ss wear ring is a press fit.

    By the way, Careys pump is headed to skat for the tripple bearings and ss wear ring tomorrow too

  3. #3
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    i have the same problem right now... guess its the cold

  4. #4
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    I hope it has a better fit than this POS.

    Are you going to get a prop or wait a bit longer for more R&D?

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    I already have several 3 blades. Just waiting to test them and try different things. I was going to test a 3 blade in Carey's ski today, but ended up pulling a muscle in my back stayed in bed all day

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,466
    +1
    3
    when i was testing the SC and ECU last week and swapping props... i pulled the pump off, put it in a vice upside down on the impeller tool, and the wear ring just kept falling out... then when put a diff prop in and flipped the wear ring over and spun the prop, the wear ring would spin with the prop sometimes.... wonder if it's doing that when there's a load on the pump, that would suck

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,983
    +1
    1,900
    I had a conversation with Glen at Skat about this and he said its nothing to worry bout. By the way, under load the wear ring is not spinning in the pump. The pressure holds it tight.

  8. #8
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    Maybe you could drill and tap a set screw in place to hold it.
    Just drill into the ring a few thousandths so not to press in on the ring only hold it from spinning.

  9. #9

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1

    wearring spin

    when the pump unit is bolted back on the ski it should'nt spin, but check for signs of spinning when removed.

  10. #10
    David 1 FAST VE's Avatar
    Join Date
    Jun 2005
    Location
    Southaven, MS
    Posts
    1,958
    +1
    1
    I did not notice any but still do not like the idea that it was happening?

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wear Ring Problem
    By rxpvic in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-02-2011, 08:19 PM
  2. Odd Wear Ring Problem on 99XP Ltd Help me help my buddy!
    By 1 FAST VE in forum 2-Stroke Performance
    Replies: 23
    Last Post: 07-25-2010, 09:09 PM
  3. Impeller binding on wear ring.. problem or symptom?
    By NoGo1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 09-21-2008, 11:33 AM
  4. wear ring problems
    By RiverRat19405 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-07-2007, 03:35 PM
  5. 2003 GTX Supercharged wear ring problems
    By Zilla57 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-10-2006, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •