Results 1 to 3 of 3
  1. #1
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826

    Cool 2004 MSX 150 loss of RPMs....

    First visit to this great forum...and I bring a new problem that happened today. Cruising along just fine, until I reached around 6000 RPM. I hear this short PHFFT (like a relief valve doing its thing), and the engine drops down to about 4200 max, and the 'check engine' light comes on. Kill the engine...wait a few minutes...and she fires off just fine. Everything goes well as long as I limit the RPM's to the high 5000 range. No more 'check engine' warning. But you guessed it...just as soon as I take it to 6000, here comes the PHFFT sound, the engine backs down to the 4200 range, and the light comes back. This happens every time....

    This ski has been running beautifully until today...speeds around 62 MPH with two adults, and RPM's around 7450. Any suggestions?


  2. #2

    msx 150 slow down

    ck water going and clean intercooler prob. overheat. happens on seadoos all the time

  3. #3
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    I'll definitely check that out...although I never got an 'overheated' indicator (and this ski is very sensitive about running temps)!

    Thanks for your suggestions!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 MSX-150 Surges and MAX RPM 5850
    By rcsscraig in forum MSX/Matrix
    Replies: 37
    Last Post: 09-09-2015, 06:53 AM
  2. MSX 150 Loss of RPM
    By steelroe in forum MSX/Matrix
    Replies: 2
    Last Post: 10-13-2012, 07:54 PM
  3. 2004 msx 150 black carbon plugs and limited rpm
    By Joe dana in forum MSX/Matrix
    Replies: 2
    Last Post: 06-27-2010, 11:18 PM
  4. Help! Loss of RPM's on 150 Speedster
    By alloy89 in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 07-03-2009, 03:49 PM
  5. 2004 MSX 150 loss of RPMs....
    By Rocky_Road in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-31-2007, 06:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •