Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2007
    Location
    united arab emirates; abu dhabi
    Posts
    98
    +1
    1

    do i have to open the exhaust?

    there is a little bit of water came through the filter.. do i have to open the exhaust to clean it.. is there any other way?
    gp1300 2006


  2. #2
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Do you mean water came through the air filter ?

  3. #3

    Join Date
    Mar 2007
    Location
    united arab emirates; abu dhabi
    Posts
    98
    +1
    1
    Quote Originally Posted by mrbtd View Post
    Do you mean water came through the air filter ?
    yes water came through the filter

  4. #4
    flyboy's Avatar
    Join Date
    Nov 2005
    Location
    Destin, FL
    Posts
    1,585
    might have to change the plugs, but other than that run the S H Y T E out of it, to get the water out

  5. #5
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    Quote Originally Posted by flyboy View Post
    might have to change the plugs, but other than that run the S H Y T E out of it, to get the water out
    +1

    Assuming it starts and runs - just run it you dont need to take it apart or anything just get all the water expelled by riding it.

    It it doesnt start then you need to empty the cylinders of the water by cranking it. Once you get it started run it ASAP for a good 30 minutes (in the water). You dont want any hints of water in your engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. If you blow a piston, do you have to rebuild the ENTIRE motor?
    By espritonsevas in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 04-21-2009, 10:05 AM
  2. Do I have to remove the exhaust chamber?
    By Jetscreamer in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-11-2008, 12:25 PM
  3. Do I have to loose the opas to run the Free Flow 06 RXP
    By OHIOJOE in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-19-2008, 09:14 AM
  4. Do you have to seal the ride plate right away??
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 09-19-2007, 07:03 PM
  5. Instaling my BOV do I have to use the middle notch????
    By Jrsrxp in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-22-2005, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •