Results 1 to 3 of 3

Thread: bad battery?

  1. #1

    Join Date
    Dec 2006

    bad battery?

    well i just got a battery like 6 months ago and ever since i charged it up my rxp wont turn over the first click if i keep doing it it will finally start after a couple clicks what could be the problem?

  2. #2
    bigrich007's Avatar
    Join Date
    Apr 2007
    Check your fluid levels of battery.

  3. #3
    qbzonk's Avatar
    Join Date
    Aug 2006
    Yup, I just had the same problem with a 5 month old Autocraft battery I got from my local auto parts store. I kept it on a battery tender and low and behold it would crank. When I checked the electrolyte levels, they were very low.

    If you're battery isn't a "maintenance free" battery, then more than likely you're low on electrolyte. You can pic up more cheap at your local auto parts store.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP800R Bad Battery/Running Issues
    By 800n in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-26-2013, 08:52 AM
  2. Help a newbie! MFD dead after short/bad battery connection.
    By Picto in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-02-2010, 11:19 PM
  3. Bad battery? other probelm? please help
    By RXPteamtimebomb in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 04-07-2009, 03:36 PM
  4. bad battery?
    By skatealnight in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-09-2007, 01:52 PM
  5. Bad battery cable
    By smackwave in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-24-2007, 07:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts