Results 1 to 4 of 4

Thread: help

  1. #1

    help

    Hi I have a 1997 sl 900 the problem is if you crank it over it will spark once and not again if you stop cranking and do it again it will spark once and not again this keeps happing what could be the cauls
    Also will a cdi part number 4060180 fit. the one that is on it is 4060170


  2. #2
    Watcon's Avatar
    Join Date
    Oct 2005
    Location
    Seattle WA
    Posts
    872

    Help.

    You need a new stator... I suggest purchasing the ignition upgrade kit, as it will solve many problems at once. I have them available, but feel free to purchase from your local dealer if they have them in stock..

    Regards,
    Randy

  3. #3
    1996 SL900 & SL700 turk0004's Avatar
    Join Date
    Jul 2007
    Location
    Chicago IL
    Posts
    328
    Check you battery voltage while cranking. Mine did the same thing and found my battery was @ 10.1 volts while cranking. Charged the battery and it fired right up...also replaced the bad battery.

  4. #4
    Watcon's Avatar
    Join Date
    Oct 2005
    Location
    Seattle WA
    Posts
    872

    Spark.

    Excellent call.. I always forget that not everybody realizes that all Polaris need a GOOD fully charged battery.. I realize that people will disagree, but if you aren't sure hook up the jumper cables to your car.. You need good amprege that you can't get from a battery charger.. Be sure to test your spark first with the plugs removed first..

    Thanks,
    Randy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2005, 07:49 AM
  2. RXP Handling !! Anyone help please
    By rxp_boy in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-17-2005, 02:33 PM
  3. help!!!
    By jonstephens in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-16-2005, 10:47 AM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •