Results 1 to 7 of 7
  1. #1

    Why does it take about 10 min to have normal performance?

    Hi folks!
    I have a 05 RXP with about 45 hours on it. For about the first 10 minutes or so of riding, it has really poor acceleration and only tops out at about 50MPH (speedo). Once the thing is warmed up, the acceleration is fine and the top speed is at 70MPH(speedo), like it is supposed to be. Can anyone tell me what might be wrong.

    Thanks!
    Ed


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by Ed View Post
    Hi folks!
    I have a 05 RXP with about 45 hours on it. For about the first 10 minutes or so of riding, it has really poor acceleration and only tops out at about 50MPH (speedo). Once the thing is warmed up, the acceleration is fine and the top speed is at 70MPH(speedo), like it is supposed to be. Can anyone tell me what might be wrong.

    Thanks!
    Ed


    That ain't right....I've never experience that....

    I usually let me ski warm up for about 2-3 minutes of idling around, then take it easy up on plane for about 3-4 minutes...then everything is fine....She's a little sluggish until a bar or two drop on the gauge, after that she wakes up...

  3. #3
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Check your RPMs if its around 6000 maybe your S/C needs a washer medic.

  4. #4
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    Change the plugs....running on 2 cyls. then the 3rd hits.....sound about right or what? I mean, u ride it and it suddenly wakes up or what?

  5. #5
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,528
    +1
    4,755
    Never seen this...
    try the plugs first, maybe your sc is going south... PM Jerry see what he says.
    Last edited by YoYamma; 09-01-2007 at 09:46 PM.

  6. #6
    75 mph on a budget TorquePhoto's Avatar
    Join Date
    Jul 2006
    Location
    Lake St. Clair, MI
    Posts
    360
    sounds right to me....

    Quote Originally Posted by 9secZO6 View Post
    Change the plugs....running on 2 cyls. then the 3rd hits.....sound about right or what? I mean, u ride it and it suddenly wakes up or what?

  7. #7
    you should always warm it up before putting a beatin on it, let the engine warm up to allow expansion of moving parts and to allow thermostat to operate.
    regardles tho, I agree , stick a fresh set of plugs in there first...PR...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What does it take for an RXP To out accell an RXP-X
    By mackey in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-30-2008, 08:27 PM
  2. How Long Does It Take For Riva To Get Their Shipments IN??????
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-25-2007, 01:40 PM
  3. what does it take to turn a 14/20 without going too deep?
    By bow tie klr in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-07-2006, 12:29 PM
  4. What does it take for a GP1300R to beat an RXP?
    By Lurker in forum 4-Tec Performance
    Replies: 29
    Last Post: 09-16-2005, 12:49 PM
  5. Riva Stage 1 kit (how long does it take to install)
    By macattack in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-20-2005, 04:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •