Results 1 to 6 of 6
  1. #1
    coyle2285's Avatar
    Join Date
    Aug 2007
    Location
    Keller Tx
    Posts
    4

    2005 RXT Question

    Well over the weekend i let someone ride the ski and they ran through some grass on the lake and it got stuck in the ski and it got hot and blew out the sensor in the waterbox. Also on the exhaust the rubber hose that connects to it has got a piece of plastic that has cracked on the bottom and the ski died in the middle of the water and got lots of water in the engine compartment and it wont even start now. It sounds almost like the battery is dead and i tried jumping it off and it wont turn over, it just clicks and clicks but never turns over. I have the sensor coming in on tuesday but is this why it wont start because of the sensor being out. On the gauge it says sensor and im relacing that sensor so im sure that will stop after i replace the sensor. Also since all the water got in the engine compartment i tried getting as much water out as possible but i noticed in the waterbox it still has lots of water, how can i get all the water out of the system since i cant start it up or what is causing it not to start? Thanks


  2. #2
    HoopsRXT's Avatar
    Join Date
    May 2006
    Location
    Wausau, WI
    Posts
    360
    You may have something stuck in the pump not allowing the engine to turn over. Look up the intake on the bottom and see if there is anything in there. You may need to remove the grate to get a good look.

    Otherwise you may have digested some water into the engine. It maybe hydolocked (can't turn over due to water in the cylinders). You can try removing the spark plugs and see it is cranks over with the spark plugs out. Be sure to have the coils un plugged while trying to crank over when you have the plugs out.

    These are two areas to look at.

    Also be sure to replace the ceramic supercharger clutch washer with the metal ones if you haven't already. THis is very important!

  3. #3
    coyle2285's Avatar
    Join Date
    Aug 2007
    Location
    Keller Tx
    Posts
    4
    alright man i appreciate the help.. im gonna mess with it for a bit in the morning until i get ready to go to the lake. Ill give some more info after i mess with it.

  4. #4
    Will work on YOUR ski for FREE! GeoRXT's Avatar
    Join Date
    Mar 2006
    Location
    Miami, FL
    Posts
    4,438
    +1
    1
    Did you run it with water inside the engine compartment? Did you try to start it with water in there? When was this? I dont think it can hydrolocked so quick....?

  5. #5
    coyle2285's Avatar
    Join Date
    Aug 2007
    Location
    Keller Tx
    Posts
    4
    Well i didnt know water was in there until i was riding across the lake and all of a sudden it just died and i got off and noticed the back of the jet ski was sitting low in the water and i tried starting it back and it would just click so i waited until someone came by and could give me a pull back to land and then i pulled it out the water when it came to land there was water coming out of it like a waterfall. Then i took the seats off and noticed lots of water and since then it would not start. I took the sparkplugs out today and noticed water in there. Does this mean the engine is no good. I dont have any water mixed with my oil though. So not sure what is going on.Thanks for the help

  6. #6
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,556
    +1
    4,774
    Get it to your dealer have them check it out...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new to me 2005 rxt, few questions
    By blacktop in forum 4-Tec Performance
    Replies: 21
    Last Post: 05-28-2013, 07:35 PM
  2. 2005 RXT VTS install question
    By JohnW in forum 4-Tec Performance
    Replies: 17
    Last Post: 03-15-2013, 03:41 PM
  3. Questions About Re-installing Factory Intake Grate on 2005 RXT
    By lt1pwr in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 09-26-2012, 10:09 AM
  4. 2005 RXT S/C and Valve Question
    By ghlenz in forum 4-Tec Performance
    Replies: 0
    Last Post: 09-09-2011, 11:21 AM
  5. 2005 RXT questions
    By Small Paul in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-05-2009, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •